AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Bobman

Regular Member
  • Content count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Bobman

  • Rank
    Newbie

Profile Information

  • Would you be interested in attending club meetings?
    Yes
  • Toyota Model
    Avalon
  • Toyota Year
    2003
  • Location
    Victoria
  • Annual Mileage
    10,001 to 15,000

Contact Methods

  • First Name
    Bobby
  1. Avalon MkIII Intermittent Starting Issues

    While I haven't tested the fuel pump during cranking, it does run very well and there is no buzzing which usually indicates a failing fuel pump. I believe I've narrowed the issue down to Crank Angle Sensor or Ignition Switch. I believe it's the former and will change it this week. Interesting that it will always start if the key is left 'ON' for a few minutes, almost like it primes the faulty sensor(s) or resets itself somehow.
  2. G'day, Just picked up an Avalon MkIII GXi. I own 4 Fords, but worked around Avalons 2001-2006 at a taxi depot, so always had a soft spot for them etc. Have an interesting starting issue with a workaround I found. Has anyone ever heard of issues with the ignition switch on these? Igniter? Crank angle sensor? Knock sensors? It has had aftermarket keys for 5 years now. The light goes off instantly upon insertion indicating it has been programmed as a master. Now, it will just crank endlessly often. The workaround is to leave the ignition 'ON' for 5 minutes and then it starts no worries until the next time. Any ideas?