AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Pockimon

2010 Camry Hybrid Low Beam, has anyone upgraded from OEM bulbs?

6 posts in this topic

Hi Guys,

I have a 2010 camry hybrid. I would like to upgrade my low beam lights to LED. I was looking at this item:

http://www.ebay.com.au/itm/H7-LED-Headlight-Bulbs-Conversion-Kit-Super-Bright-White-Headlamp-Toyota-Camry-/351632664674?hash=item51def0a862:g:h-sAAOSw44BYHUmh

Has anyone done this before? if so please let me know how it is. Also advice on installation would be appreciated. 

 

Thank you.

Share this post


Link to post
Share on other sites
 

Am thinking the same, non hybrid 2017 Camry sx

Share this post


Link to post
Share on other sites

There is a similar thread in the Aurion Forum titled LED Headlights. 

Check with your Transport Dept but I expect you may find that the conversion will be illegal.

A better option may be to upgrade the halogen bulbs. Next option would be a LED light bar.

Share this post


Link to post
Share on other sites

LED headlights like the ones posted above are terrible, the output is worse than halogen. Do your headlights have factory projectors? If so, a 35W HID kit with 4500k bulbs will give decent output. If your headlights are just a halogen reflector housing then get some of these: http://www.ebay.com.au/itm/Philips-Xtreme-Vision-130-More-Light-H7-Headlight-Globes-Twin-Pack-of-Bulbs-/271866779766?hash=item3f4c85d876:g:tScAAOSwuxFYx8PA

TLDR; stay way from LED

Share this post


Link to post
Share on other sites

I have noticed when looking at the different halogen bulb specifications, high output bulbs usally have a shorter lifetime compared to extra performance and standard bulbs. Just something to be aware of when selecting/comparing bulbs.

http://www.carbulbsdirect.com/au/store/category/car-bulbs/fitting/h7-499

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By krigeroz
      I was about to replace my halogens bulbs with led ones and just found that they are illegal In Australia...
      Have anyone replaced their halogens lights with LED ones?
      https://www.racq.com.au/cars-and-driving/safety-on-the-road/driving-safely/headlights
    • By Pockimon
      Hi All,
      I can hear what appears to be a chirping/cricket like noise coming for the rear area of my camry 2010 hybrid. Its faint but it gets annoying after a while. It does not occur when car is stationary, only when it is moving forward. 
       
      Any ideas what it may be ? 
    • By WhiteZre182r
      Hey guys, I own a 2014 Corolla Ascent Sport Hatchback and was wondering if anyone knows where I could find some after market LED tail lights if it's possible. Thanks! :)
    • By thetallbloke
      Hi All,
      I have a 2010 Tarago and the brake lights on one side don't come on.  They are in a cluster of LEDs that come on when the headlights are turned on, just brighter when the brakes are pressed.  These are the ones that are on the main body of the vehicle, as opposed to the boot.  Incidentally, this seems to be the same side that the towbar wiring has been spliced into.
      I'm just wondering what could be the issue and whether this has to go back to Toyota to fix or can I just replace a fuse (or probably an expensive black box) to get them working again for a rego check.
      The LEDs come on when the headlights are turned on, but don't go brighter (like the other side does) when the brake is pressed.  I've had a look at fuses that I can find in the foot area on the driver and passenger sides, but the labels are a little cryptic so I'm just guessing which ones to check.  I'm about to pull every one out and individually check them all.
      Does anyone have any clues on what to check???
      Thanks in advance.
    • By GrantKluger
      Hi All,
      Anyone have any preknowledge of this problem,
      Was driving up the M1 the other day and going up a hill in my 2010 kluger AWD and as it was about to change to a lower gear to get up the hill it had a hissy fit, couldnt decide what gear to take and stayed in the top most gear, basically it felt like I was trying to go up a hill in neutral, pulled off to side of road, stopped engine and restarted , went to accelerate into traffic and couldn't even get it past 40km/h, pulled into an emergency telephone and requested a tow. Car had no pre warning, no dash lights and engine was running fine, in fact I left the car idling for the 3 1/2 hrs it took to get us picked up. Any ideas? besides an expensive issue???? Thanks
  • Recently Browsing   0 members

    No registered users viewing this page.