AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Canon_Spec

[NSW] BNIB HKS S-Type Oil Cooler Pro Kit 86/BRZ

Recommended Posts

Item: HKS S-Type Oil Cooler Pro Kit 86/BRZ - Part No: 15004-AT011

Location: Sydney, NSW

Item Condition: Brand New in Box - Only opened to inspect contents

Reason for Selling: Selling I as I no longer need it.

Price and Payment conditions: Price is $1000 - Can post at buyers expense. Pick up at 2000 BH, 2560 AH.

Feel free to PM for more details.

18010097_10154389764292401_1401087096939640195_n.jpg.c43a1586a1cfa372be332d6cca68748d.jpg

Edited by Canon_Spec

Share this post


Link to post
Share on other sites
 
Sign in to follow this  

  • Similar Content

    • By PengNZ
      Hi guys, i just replaced my engine oil with 6.1L Nulon 5w-30 SN Long Life. But the oil level is higher than the high dot on the dipstick when the engine was stone cold. Just wondering what’s the best time to use the dip to check the oil level? Stone cold or after warming up? Cheers
    • By warren cameron
      have camry 2015  2.5 pros/cons ading moly bond oil additive thanks warren
    • By Hamzstreet
      Hi guys I've had my 2010 ATX aurion for about 8-9months now , I've run across a few problems so far list being 
      castor bushes 
      engine check light with no traction control light 
      failure of intermediate steering wheel shaft (clucking and tapping noise) 
      I always maintain this car as much as I can, I service the car (oil , oil filter and the rest myself ) every 7-8000km 
      I use castrol edge 
      k&n air filter 
      genuine oil filter 
      just did a genuine fuel filter and fuel pump filter change on it 
      i have dba t2 slotted rotors (front and back) with bendix pads 
      running on a set of Bridgestone potenza re003's 
      ao my problem is that 
      i drove off off my drive way today and saw a bit of oil on the drive way which scared me Abit , so I quickly jumped under the car and saw oil leaking from this location (I'll put up a pic) can anyone please tell me what's going on here ? 
      Also the car is very loud like tapping noise when I cold start it and in general sounds like a tractor plus I get this loud pig like squeezing for about 10min on a cold start (😑) pls help 

    • By CheekySportivo
      Hi guys,
      I've noticed my Sportivo has left a small spot of red/pink fluid on the garage floor.
      As it was located at the front drivers side I'm presuming it is power steering fluid.
      Has anyone else experienced this type of leak on their Sportivo?
      Would it be best to take it to a dealer or can anyone recommend a professional mechanic in Sydney who knows what they are doing and uses genuine parts?
      Thanks in advance :)
    • By Rollersk8r
      Hi all,
      Bit of a long story...
      I have owned this car for around 6 years and generally been pretty happy with it. However, around 12-14 months ago I began to get random warning lights coming up - mainly the engine and VSC (orange ones). They might come up a couple of times in a week, and then not again for months.
      Anyway - I have taken the car to Toyota dealers 6 or 7 times to chase up these errors, not including regular services - and basically got the same response each time: "Yeah we saw some error codes, couldn't find any problems during testing, cleared the codes, you're right to go".
      Then, about a month ago, I was finding the car would sometimes have a lag in engaging drive. The engine would rev and it would suddenly clunk into gear a couple of seconds later. So Toyota said this was beginning to sound like a transmission problems - and I should start by flushing and replacing the transmission fluid, which I paid around $200 to do.
      Then yesterday the engine starts making a horrible clattering sound. I was close to home and noticed it was leaking red fluid. I was fairly sure this was transmission fluid. Wasn't sure if I should drive the 5 or 6km to Toyota, but did anyway.
      Toyota are now saying this latest problem is nothing to do with transmission, it's leaking engine oil from a burst line, will be approximately $600 to repair - and they're not even sure if the engine is ok - because it did lose almost all of the oil.
      I have seen posts here and other stuff online about the V6 engine oil line and failures. But does this sound right to people??
      I take obsessive care of the car. It has done 160,000km - but has cost me well over $1000 this year in servicing and repairs. Was hoping to get at least a couple more years out of it but I'm starting to wonder... Plus I was sold on the fact that Toyota keep comprehensive service records of the car, since before I owned it, which might avoid these sorts of issues coming up.
  • Recently Browsing   0 members

    No registered users viewing this page.