AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Ivan75

Speedometer troubleshooting

Recommended Posts

Ivan75    0

Hi all,

I recently removed the instrument panel from my Hilux (2006, KUN26R) and cleaned the internals (it was very dusty). I was gentle when doing the cleaning, although the needles on the gauges moved a bit as I did the cleaning (but nothing significant).

When I replaced the instrument panel and took the car for a drive, all the gauges worked except for the speedometer. The odometer is also working normally.

Is anybody able to let me know whether there's a way to repair/rectify this problem?

Any feedback much appreciated.

Thank-you, Ivan

Share this post


Link to post
Share on other sites
 
trentmeyer23    467

I assume it worked correctly before you touched it?

They are very, very easy to bend, so that would be the first place I would check.

Share this post


Link to post
Share on other sites
Ivan75    0

Thanks very much Trent. Yes, it worked fine before I cleaned it.

Do you happen to know how I'd go about straightening it, if that's the problem?

Share this post


Link to post
Share on other sites
trentmeyer23    467

Well it depends on if/how much damage has been done. You may be able to bend it back or you may need to replace it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.