AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


warek

VSC Error, code for engine fan but seems ok

Recommended Posts

Hi there

We have a 2008 ZR6, 135000 gentle kms, driven in country by mature aged lady driver, mainly on short trips to work, about 6kms one way. For the last few months, intermittently, the information light comes on along with engine malfunction light, and VSC warning message on dash and VSC/traction light on as well.

Sometimes it clears itself, and usually comes on when making a turn after stopping at an intersection, or can come on going around a bend,  It may come on when you start the car and then not come back on next time we start the car.

My son has equipment to read the code and looked up the error code and it says it is the engine fan warning.

The engine fan appears to work as expected, comes on when engine hot and shuts off as expected. No unusual readings on temperature guage.

Any suggestions as what to do now?

Have a good day

Cheers

Kevin

 

Edited by warek

Share this post


Link to post
Share on other sites
 

You could check, does the fan come on when the ac is turned on, it should. There could be a fault there

Share this post


Link to post
Share on other sites
On 11/23/2017 at 8:36 PM, matt36415 said:

You could check, does the fan come on when the ac is turned on, it should. There could be a fault there

Thanks for the suggestion,  tested that and fan does come on when Air cond is on

Cheers

Kevin

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • By mznashiz
      Ok so i bought an 06 aurion sportivo from townville put it on a car carrier to Brizzy and went and picked it up and it has the VSC error come up managed to take it to a toyota dealer and the young bloke so kindly reset the codes and told me my back tyres were screwed so getting new tyres as we speak, anyways we turned the car off and the damn code has come back on!!! what the hell??? we have spoken to a number of different toyota mechanics who suggested different things is it possible the back tyres are that bad it keeps giving this warning like i said we are getting new ones but wondering if this is a common cause or what???
  • Recently Browsing   0 members

    No registered users viewing this page.