Jump to content


HiLux 2.8D electrical problem HELP please (needed for work)


Phill
 Share

Recommended Posts

I have a Hilux 2.8 D 1989 4x4 with an electrical problem. This occurred while driving. First indication of a problem was loss of indicators and No Charge light came on. Drove it straight home fearing that if I turned it off it wouldn't start...proved to be true.

I have checked fuses in the drivers side kick-panel, fuses & links in the engine bay, wiring loom visually, un-plugged and re-plugged wiring loom connections, wriggled everything I can find, all whilst having the key on and wipers, indicators etc turned on in case I got a flicker of something working.

Here is what is & isn't working:-

Hazard Y

Horn Y

Head/l Y

Dome/l Y

Fuel cut-off relay Y (audible click)

Glow relay Y (audible click)

Tail/l N

Parkers N

Wipers N

Temp/G N

Brake/l N

Heat/fan N

Starter motor N

And the NO Charge light stays ON

I have looked at the wiring diagram and can't find anything that looks common to all the non-working items.

The only thing that caught my eye was wire B Y from the ignition switch. It seems to have a few of the non working items attached to it, but before I go ripping into the dashboard, I would appreciate some other opinions.

Is there a in-line fuseable link that isn't in the Gregorys manual maybe?

Any suggestions greatly appreciated.

Thanks in advance,

Phill.

Edited by Phill
Link to comment
Share on other sites

hey mate

have a look in fuse box under the bonnet and just unplug your relays just in case one of them is stuck as i had the same problem. may also have somthing to with the alternator??

cheers joe

Thanks Joe.

I did that and I have discovered that there is no power getting to the ignition switch, but there is power from the fuse links, but it is not getting to the ignition switch for some reason.

Cheers

Phill.

Link to comment
Share on other sites

  • 7 months later...

Hi Phill,

Did you get this sorted?

I seem to be having a similar problem. There seems to be no power to the starter and everything in the driver's side kick-panel doesn't work. And i don't have a Gregorys to be able to look at a diagram of the electrical wiring.

Any advice?

Much appreciated.

Cas.

Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 34

      Coolant Leak 2008 Aurion

    2. 2

      Looking for a hard to find part

    3. 74

      White Pearl Paint cracking & peeling on a Prado

    4. 74

      White Pearl Paint cracking & peeling on a Prado

    5. 34

      Coolant Leak 2008 Aurion

    6. 34

      Coolant Leak 2008 Aurion

    7. 0

      looking looking

    8. 0

      Suspension

    9. 0

      How to change front wheel bearing 2009 corolla

Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...

Forums


News


Membership