Sign in to follow this  
gigiboy

help me pls with my 2zz-ge engine

Recommended Posts

my vvtl-i doesnt go of when im at 6000rpm...then my check engine indicator light will turn on, then my cut-off rpm becomes 7200rpm instead of 8000rpm...what will i do about this problem?

Edited by gigiboy

Share this post


Link to post
Share on other sites

usually your cut off RPM is at 7200rpm when your engine is cold. so all i would think is that its still cold, but yeah i thought id give u my 2 cents cos no 1 else has given any feedback yet, im sure every one will soon though

Share this post


Link to post
Share on other sites
usually your cut off RPM is at 7200rpm when your engine is cold. so all i would think is that its still cold, but yeah i thought id give u my 2 cents cos no 1 else has given any feedback yet, im sure every one will soon though

even though i let the engine started for about 10 mins. no improvement....the same problem which i posted earlier...

Share this post


Link to post
Share on other sites

The engine oil must be above a certain temp (60 degrees?) in order for lift to kick in, and the limiter to set at 8K revs.

Are you revving the engine in neutral?

Share this post


Link to post
Share on other sites
The engine oil must be above a certain temp (60 degrees?) in order for lift to kick in, and the limiter to set at 8K revs.

Are you revving the engine in neutral?

definitely im not revving the engine in neutral...my vvtl-i doesn't go of while the car is running in 600rpm, the check engine indicator will light on when i reach 6000rpm, then my cut off rpm becomes 7200 rpm instead of 8000 rpm...pls help me guys..thanks...

Share this post


Link to post
Share on other sites

If your getting the check engine light probably best to take it to someone with a scan tool, Toyota or other suitably equiped workshop will be able to read the code(s).

Share this post


Link to post
Share on other sites

it would be really helpful if u gave us all some more details like the brand/grade of oil that u're using, when the last change was or the last service. no one has a crystal ball ;)

personally, i think your best bet is still to bring it down to a workshop like wat SuperDave said.

Share this post


Link to post
Share on other sites

because when i gone cheap and service withe valvoline(dont know if thats how u spell it) oil and in first gear u cant feel lift kickin in, the oil was fresh and etc but the car just didnt like it, now i use helix semi synthetic problem is gone

also have u try reset your ecu?

Share this post


Link to post
Share on other sites
the check engine indicator will light on when i reach 6000rpm

Umm... take it to a professional and get it checked

:blink:

Share this post


Link to post
Share on other sites

So what is the best oil for the 2zzge. coming up to my first service as a second hand owner for my car and i want to go out and buy the best oil for my car even if it costs hundreds of dollars.

Share this post


Link to post
Share on other sites
So what is the best oil for the 2zzge. coming up to my first service as a second hand owner for my car and i want to go out and buy the best oil for my car even if it costs hundreds of dollars.

Check Northy's previously covered topics thread for a bunch of oil threads. The best one was called "oils ain't oils". There are many schools of thought as to synth vs mineral and different weights.

Share this post


Link to post
Share on other sites
it would be really helpful if u gave us all some more details like the brand/grade of oil that u're using, when the last change was or the last service. no one has a crystal ball ;)

personally, i think your best bet is still to bring it down to a workshop like wat SuperDave said.

im using a mobil 1 fullysynthetic.. im using it for about 8000km now...do i have to replace it with a new engine oil?what brand you will recommend for me?thank you all guys...

Share this post


Link to post
Share on other sites

that is ok but change it every 5000k's. sounds like an ECu glitch. Back to toyota.

Share this post


Link to post
Share on other sites
my vvtl-i doesnt go of when im at 6000rpm...then my check engine indicator light will turn on, then my cut-off rpm becomes 7200rpm instead of 8000rpm...what will i do about this problem?

what's a ecu glitch?thanks...

Share this post


Link to post
Share on other sites
my vvtl-i doesnt go of when im at 6000rpm...then my check engine indicator light will turn on, then my cut-off rpm becomes 7200rpm instead of 8000rpm...what will i do about this problem?

what's a ecu glitch?thanks...

a problem with ur ecu ..... mate i think its pretty simple .... go back to toyota and get them to sus it out .... the fact that its not engaging lift and then showing u a CEL could be due to so many things its not funny ..... get them to tell u wat the issue is.

Share this post


Link to post
Share on other sites

Did this car come from factory with a 2ZZ engine or was the engine fitted after you bought it?

Share this post


Link to post
Share on other sites
Did this car come from factory with a 2ZZ engine or was the engine fitted after you bought it?

i fitted the engine after i bought my car...ived change my oil already with the same brand..Mobil1 fully synthetic oil,oil level is at the full level..but still its the same problem..toyota here in the philippines cant help me because im the only person here who has this kind of engine..i brought it once in the toyota service center, but they dont have the code of my engine in their computer...i bought my engine from japan then imported it here in the philippines...

Share this post


Link to post
Share on other sites
Did this car come from factory with a 2ZZ engine or was the engine fitted after you bought it?

i fitted the engine after i bought my car

Thought so.

Share this post


Link to post
Share on other sites
its your fuel map - its got a nasty hole... thats why you're unloading in third.

just tune the NOS timer and you'll run 9s

lol

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this