Jump to content


Avalon Electrical Problem


67Rolla - Ken
 Share

Recommended Posts

Hi all,

I have a major problem with my 04 Avalon. The car starts and runs fine, the headlights work & the hazard lights work. NOTHING ELSE ELECTRIC IS WORKING!! Radio, indicators, mirrors, windows, odomiter, trip computer, aircon, wipers, etc all dead.

I didn't think any one fuse had control over all these, and all the fuses look fine.

I did get a new deck fitted about 3 weeks ago, but that was fitted by the best crew in WA (in my opinion) and these guys don't make many mistakes, plus it has worked fine for 3 weeks.

This car is my bunky, my daily runner. Desperately needed while 67Rolla is off the road. I brought her cos I thought she'd be reliable...

Anyone have any ideas how to fix this??

Link to comment
Share on other sites


I don't have a tester light thingy, and as my car is FU**ED I can't go get one!

I don't think it's a fuse, I think it might be a relay. Just got to figure out which one... Car has about 10 to choose from, in the 4 fuseboxes :(

Edit: and the things listed under "DOME" fuse, are also all still working (all the useless little lights).

Edited by 67rolla
Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 6

      Kluger Sat Nav DVD Map File

    2. 3

      Kluger vs Prado vs RAV4

    3. 0

      2005 Rav4 2 door cruiser

    4. 34

      Coolant Leak 2008 Aurion

    5. 2

      Looking for a hard to find part

    6. 74

      White Pearl Paint cracking & peeling on a Prado

    7. 74

      White Pearl Paint cracking & peeling on a Prado

    8. 34

      Coolant Leak 2008 Aurion

    9. 34

      Coolant Leak 2008 Aurion

Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...

Forums


News


Membership