Jump to content


MY 1993 TARAGO GLI DOESN'T RUN TOO WELL


ANTIPOD

Recommended Posts

was it making the pinging sound when you bought it?

what happened when you fisrt started to notice the ping?

what type of fuel are you using?

and welcome to the forum :)

I DIDN'T HEAR THE PINGING WHEN I BOUGHT IT

I NOTICED IT HAPPENED AROUND 2500 RPM UPHILL UNTIL ENGINE WARMS UP THEN IT ALMOST DISAPPEARS

I HAVE USED NORMAL UNLEADED AND HIGH OCTANE BUT IT MAKES NO DIFFERENCE

Link to comment
Share on other sites

Dirty. DIRTY old wombat. Chances are you'd be able to ping at least 6 grands worth of work on the thing. And i haven't even seen the car.

Replace the worn sad shaft, reseal that horrible sump, fix that leaking rocker side cover, give it a service, go from there. Put a set of leads on it too.

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 5

      RAV4 19" wheels on Aurion

    2. 1

      Drivers side mirrors - zze122 vs zre122

    3. 2

      Brake issues with 2024 Corolla Cross Hybrid

    4. 1

      Drivers side mirrors - zze122 vs zre122

    5. 2

      Highest and lowest diff ratio

    6. 0

      RAV4

    7. 0

      Ute Tub Swap

    8. 0

      Putting a R151F in my 1998 ln167r IFS

    9. 1

      New member

×
×
  • Create New...

Forums


News


Membership