Jump to content


'04 Camry Sportivo, Radio amplifier cuts out


xb1977

Recommended Posts

I have got a '04 Camry Sportivo, time to time the stereo speakers cut out for hours at a time, the radio still has power but the speakers are dead.

I've noticed that this mainly happens on hot days 30+ degrees. I think it has something to do with a amplifier, if there even is one.

Has anyone else ever had this happen?

Edited by xb1977
Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 3

      Forum rules

    2. 13

      Low Fuel Warning Light Flashing

    3. 3

      Forum rules

    4. 1

      Starting Issue / Stalling While Driving

    5. 4

      2019 Kluger 2WD Transmission whine

    6. 0

      2001 hilux 2.7 efi low idle

    7. 0

      Toyota Prius 2012 code

    8. 8

      RAV4 19" wheels on Aurion

    9. 1

      Starting Issue / Stalling While Driving

    10. 0

      Starting Issue / Stalling While Driving

×
×
  • Create New...

Forums


News


Membership