Jump to content

CAI problems (stalling) on a Corolla Sportivo


Recommended Posts

I have purchased a 2nd hand Corolla Sportivo 2005 and it has a CAI intake (I believe it's a TRD CAI but do not know for certain).

The car has a problem of spluttering and stalling at low revs/ neutral/ pulling up to the lights. When the car is behaving itself the engine will idle at about 1k rpm. But when it is being temperamental it will idle very awkwardly anywhere between 750 and 500 rpm or just stall. More over the problem comes and goes, i.e. some days the car will be fine and other days it will stall as I am changing down gears.

There is also another persistant problem, which may be related, of having very low power at lower revs, i.e. taking off from 1st. The car is fine at higher revs (between 3k to 5k) but again, it's the lower revs that is causing problems.

Is the problem the CAI or is it something else?

Thanks in advance for the help!

Also, I'm new to owning a rolla, so please be patient :)

Link to comment
Share on other sites

I'm no mechanic, but if I had the same problem I would be doing the following:

Try cleaning your maf sensor - there's a work shop submission here.

Reset ecu - also a work shop submission.

Clean pod air filter and ensure no cracks in rubber elbow of cai

Spray Carburettor cleaner into throttle body with engine idling.

Do iscv clean - also a work shop submission but better to get a mechanic to do it.

Replace thermostat.

Link to comment
Share on other sites


I have purchased a 2nd hand Corolla Sportivo 2005 and it has a CAI intake (I believe it's a TRD CAI but do not know for certain).

The car has a problem of spluttering and stalling at low revs/ neutral/ pulling up to the lights. When the car is behaving itself the engine will idle at about 1k rpm. But when it is being temperamental it will idle very awkwardly anywhere between 750 and 500 rpm or just stall. More over the problem comes and goes, i.e. some days the car will be fine and other days it will stall as I am changing down gears.

There is also another persistant problem, which may be related, of having very low power at lower revs, i.e. taking off from 1st. The car is fine at higher revs (between 3k to 5k) but again, it's the lower revs that is causing problems.

Is the problem the CAI or is it something else?

Thanks in advance for the help!

Also, I'm new to owning a rolla, so please be patient :)

My car does same thing when cold just needs a coupple of minutes to warm up then fine.Usually happens more when weather is cold.

Link to comment
Share on other sites

are all your vacume hoses connected/vlocked off properly?

I had a quick look and it all seems to be fine. I'll be having a good check tomorrow though when I have access to my tools. I'll probably use some snoop leak detector to check seals.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 3

      Brand new Prado 2022 with intermittent engine/transmission stutter

    2. 0

      How do I find the build month plate on 2023 Rav4

    3. 19

      2GR-FE Idler Pulleys

    4. 0

      Toyota Allex - Exhaust

    5. 0

      Alternator Wiring

    6. 0

      Phone reception on 2012 Sahara

    7. 4

      Toyota Vienta Grande Rego Papers

    8. 4

      Toyota Vienta Grande Rego Papers

    9. 4

      Toyota Vienta Grande Rego Papers

    10. 4

      Toyota Vienta Grande Rego Papers

×
×
  • Create New...

Forums


News


Membership