theDefiant1

AutoGPS double DIN

Recommended Posts

My lovely 6 stacker is dying.

I have had a good gander at people's opinions on radios etc, and came across this one:

AutoGPS site for older toyotas

It seems to be a reasonable price for what is offered (read: plug and play harness), so if anyone has played with it before, I'd love some feedback.

I wont go into my preferences for a radio right now, but if anyone has suggestions on good double DINs, I'm listening.

Cheers

Share this post


Link to post
Share on other sites

The problem with these units is that there are simply so many different variants of them hardware/software wise that without more information on the unit in question it's impossible to answer your question. From my experience the units currently on the market range from absolute crap to half-decent, and you often don't know what unit you have purchased until you get it in person.

I've just recently bought one for my Aurion and although I love it, there are a few bugs with it that I've only discovered by using it for awhile. Still, it suits my purposes so for the time being I'm happy.

Hope this helps

Share this post


Link to post
Share on other sites

Hey there Steven What are these bugs you have come across that you have now found?

Thanks

Share this post


Link to post
Share on other sites

With mine it's mainly the slow startup (solution already sorted and implemented). It's got some others but it's very difficult to put into words. Basically sometimes it won't resume play from an external source like ipod/usb until you've pushed a button on the ipod or unplugged/replugged the usb stick. With the usb's though I think it has something to do with the size, I'm using an 8gb where the manual mentions only using a 2gb.

Share this post


Link to post
Share on other sites

I bought this TC810 GPS unit from AutoGPS.com.au and received within 2 days. Pretty impressive. Installed in my Corolla and it was a great unit. Don't see any issues yet but it is now almost 3 months. Got a free cam and fixed in my boot and all seems working perfect.

I have not had any issues with the speed or any other feature. Will keep you posted if I get anything ... hope it will run long time. If anyone need any help with the wiring, just contact me through this forum and will assist ..

This is the unit I am talking about: http://autogps.com.au/in_dash_gps_navigation_system_toyota_corolla_camry_hilux_prado.php

Share this post


Link to post
Share on other sites

Just an update after three years (just found this post randomly) and the unit still working without any issues. Updated maps recently and all seems ok. btw, the link seems to have changed and I am not sure what is the new model but go to the site autogps.com.au pick your model... 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...