Jump to content

Damp smell on start up


OzSTi
 Share

Recommended Posts

Enjoying the new KX-S AWD but we get a damp smell through vents at start up that only lasts 20 sec or so.

Very dry here in Adelaide so I'm guessing it's from the A/C.

I've also noticed the usual drip of water you get from the condenser comes from the back of the car not the centre as with the old Kluger. Do our Klugers with rear A/C have two compressors, front and rear?

Anybody else noticed this damp smell we get or do I have a blocked A/C drain?

Cheers,

Michael.

Link to comment
Share on other sites

Enjoying the new KX-S AWD but we get a damp smell through vents at start up that only lasts 20 sec or so.

Very dry here in Adelaide so I'm guessing it's from the A/C.

I've also noticed the usual drip of water you get from the condenser comes from the back of the car not the centre as with the old Kluger. Do our Klugers with rear A/C have two compressors, front and rear?

Anybody else noticed this damp smell we get or do I have a blocked A/C drain?

Cheers,

Michael.

Hey mate,

My 07 KXR has always had this smell. Get it on startup, or when you turn ac off. Doesn't last too long, but bit smelly. Dealer said just the way it works, and no fix.

Apparently very common, lot of info on the USA Toyota nation Highlander(kluger)forum.

cheers

Link to comment
Share on other sites

Thanks for the reply, sounds like the same issue.

Glad to hear it hasn't caused Legionaries disease :rolleyes:

I'll still ask dealer to see what they say.

Cheers,

Michael.

Link to comment
Share on other sites

Hi,

My husband has the same smell coming from the air-con in his 2010 VX Prado. Usually lasts about 5 minutes then goes away but sometimes it lasts the whole trip. He doesn't notice it anymore because he is in the car all the time and has probably gotten used to it, whereas the kids and I think it stinks. The smell started occurring about 4 months after he got the car. At first I thought the carpet must have gotten wet or there were smelly socks or a mouldy lunchbox in the backseat., but we soon worked out it was coming from the air-con (and only in the front seat - not the backseat). I have a 2010 Kluger KX-S and the air-con is fine. In my opinion, bad smell coming from the air-conditioning = germs. I will make sure he gets it checked out at the next service.

Link to comment
Share on other sites

Is the aircon set to recirculate?

If so, change it to external air to have fresh air circulating all the time. If this doesn't work, could be a design issue allowing bacteria from moisture(air we breath, perspiration etc)forming within the AC system.

Link to comment
Share on other sites


Certainly a/c always set to fresh air, not re-circulation.

Doesn't matter whether car has been off for 15 mins or overnight to generate damp smell which does clear quickly.

Link to comment
Share on other sites

Enjoying the new KX-S AWD but we get a damp smell through vents at start up that only lasts 20 sec or so.

Very dry here in Adelaide so I'm guessing it's from the A/C.

I've also noticed the usual drip of water you get from the condenser comes from the back of the car not the centre as with the old Kluger. Do our Klugers with rear A/C have two compressors, front and rear?

Anybody else noticed this damp smell we get or do I have a blocked A/C drain?

Cheers,

Michael.

I get condensate discharge form both the front and back with my 2008 KX-S as it has two units. If you don't have any discharge from the front then the discharge pipe could potentially be blocked causing the condensate to overflow into the front passenger foot well. You may not notice it if you have floor mats installed. This could be causing the damp smell and next time you run the a/c check the footwell for dampness.

Link to comment
Share on other sites

Enjoying the new KX-S AWD but we get a damp smell through vents at start up that only lasts 20 sec or so.

Very dry here in Adelaide so I'm guessing it's from the A/C.

I've also noticed the usual drip of water you get from the condenser comes from the back of the car not the centre as with the old Kluger. Do our Klugers with rear A/C have two compressors, front and rear?

Anybody else noticed this damp smell we get or do I have a blocked A/C drain?

Cheers,

Michael.

I get condensate discharge form both the front and back with my 2008 KX-S as it has two units. If you don't have any discharge from the front then the discharge pipe could potentially be blocked causing the condensate to overflow into the front passenger foot well. You may not notice it if you have floor mats installed. This could be causing the damp smell and next time you run the a/c check the footwell for dampness.

I've just checked, I am getting discharge from front pipe as well, today at least and I didn't detect any smell this morning. Maybe I get intermittent blockage, I'll get them to check.

Link to comment
Share on other sites

  • 1 month later...

Enjoying the new KX-S AWD but we get a damp smell through vents at start up that only lasts 20 sec or so.

Very dry here in Adelaide so I'm guessing it's from the A/C.

I've also noticed the usual drip of water you get from the condenser comes from the back of the car not the centre as with the old Kluger. Do our Klugers with rear A/C have two compressors, front and rear?

Anybody else noticed this damp smell we get or do I have a blocked A/C drain?

Cheers,

Michael.

I get condensate discharge form both the front and back with my 2008 KX-S as it has two units. If you don't have any discharge from the front then the discharge pipe could potentially be blocked causing the condensate to overflow into the front passenger foot well. You may not notice it if you have floor mats installed. This could be causing the damp smell and next time you run the a/c check the footwell for dampness.

I've just checked, I am getting discharge from front pipe as well, today at least and I didn't detect any smell this morning. Maybe I get intermittent blockage, I'll get them to check.

Link to comment
Share on other sites

Enjoying the new KX-S AWD but we get a damp smell through vents at start up that only lasts 20 sec or so.

Very dry here in Adelaide so I'm guessing it's from the A/C.

I've also noticed the usual drip of water you get from the condenser comes from the back of the car not the centre as with the old Kluger. Do our Klugers with rear A/C have two compressors, front and rear?

Anybody else noticed this damp smell we get or do I have a blocked A/C drain?

Cheers,

Michael.

I get condensate discharge form both the front and back with my 2008 KX-S as it has two units. If you don't have any discharge from the front then the discharge pipe could potentially be blocked causing the condensate to overflow into the front passenger foot well. You may not notice it if you have floor mats installed. This could be causing the damp smell and next time you run the a/c check the footwell for dampness.

I've just checked, I am getting discharge from front pipe as well, today at least and I didn't detect any smell this morning. Maybe I get intermittent blockage, I'll get them to check.

Link to comment
Share on other sites

Princess - Having fun posting blanks there are we :P

Very funny - damn iPad has a mind of its own tonight.! I have now switched to the laptop instead to save myself anymore embarrassment - Don't suppose you know how to delete posts?

Anyway, what I was trying to say is that there is a filter cartridge behind the glove box in the Kluger and the Prado which can be replaced when the air-con gets a bit stinky.

Sorry about the blank posts!

Link to comment
Share on other sites

Whenever I am in Darwin for work I use the 2010 Prado work car and it has this exact issue with the a/c. It's quite bad to the point where I wind down the windows for the first 10 minutes. I just thought it was due to the humidity in Darwin and the fact the a/c is on all the time and there are many (stinky) drivers who use the car :blink:

I have read on ToyotaNation that there was a service bulletin relating to something faulty in the 2nd gen a/c which caused a bad smell. I can't remember what it was, but it related to stopping germs/bacteria.

Also, I have a 2005 kluger and the a/c is always set to circulate, have never had a bad smell from it. I also opted for the a/c clean at the last service and it made a noticable improvement to the performance of the unit and also they must have sprayed something in it to make it smell nice. I would recommend get it done at the next service if there is no fix for the smell.

Cheers

Matt

Link to comment
Share on other sites

Very funny - damn iPad has a mind of its own tonight.! I have now switched to the laptop instead to save myself anymore embarrassment - Don't suppose you know how to delete posts?

Im guessing only Moderaters can delete posts. You can definitely edit and remove the comments you made on a post. :)

Link to comment
Share on other sites

The start up smell seems to be quite common to everyone and same to me too.

I have found another smell come from the aircond as well. If you set your aircond to recirculate, whenever you press hard on you acceleration during cruising, funny smell come out from the aircond. The smell like the chemical use in saloon to curl hair.

Anyone has this experience??

Edited by JasonL
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...

Forums


News


Membership