Jump to content


Bit of steam


Recommended Posts

Hi,

So I had a drive and stuck in traffic yesterday (driven for already an hour) and during idle I noticed steam coming out of the vents from my bonnet for about 10seconds. It stopped and came back a few minutes later..

Should this be normally happening? I have noticed also that my coolant tends to be used up quicker than expected.. maybe some cracked hoses?

It's a 7AFE, @ 93,000kms..

:ph34r:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 17

      Kluger Rear Sway Bar GSU40/45

    2. 4

      New Aurion TRD owner

    3. 0

      Power issue

    4. 4

      New Aurion TRD owner

    5. 0

      I bought a Landruiser 70 Series!.. too bad it's broken!

    6. 4

      New Aurion TRD owner

    7. 1

      Newbie

    8. 1

      Newbie

    9. 0

      Cruise control

    10. 2

      Brand new Prado 2022 with intermittent engine/transmission stutter

Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...

Forums


News


Membership