freshaltise08

Headunit for toyota camry altise

Recommended Posts

Thanks sportivo2007, you re my hero. I put the "PZQ60-00161 antenna patch with the speakers" in and I got sound. I got the rest tomorrow and hope it will work with reverse camera.

I bought this for $500 and I think it better than Chinese stuff :)

  • Like 1

Share this post


Link to post
Share on other sites

I plugged these 2 harness, but my reverse camera didnt work. I think I need another harness. Would you guys give me any suggestion pls? Thanks alot

Share this post


Link to post
Share on other sites

which camera plug do you have ? can you post a picture i have two camera harness, ill upload the pictures soon my phone died loll

Share this post


Link to post
Share on other sites

Hi sprotivo2007,

Here is the connection out of my car for reverse camera and steering wheel control

CAM00276.jpg

CAM00278.jpg

And the harness I have, I chose this harness because it said it concluded camera connection, but I am wrong

CAM00279.jpg

CAM00280.jpg

Waiting for your advice bro, thanks alot

Edited by nhp

Share this post


Link to post
Share on other sites

Ok thanks for the pictures, are you using a genuine toyota camera or an after market one?

Share this post


Link to post
Share on other sites

Hi sportivo2007, the camera is genuine one. I think it needs a harness, but I dont know which one is suitable. Waiting for you bro. Thanks alot

Share this post


Link to post
Share on other sites

Hi bro the camera connector comes together with wheel control in the first 2 pictures I uploaded. That is why the harness I got is not suitable

Edited by nhp

Share this post


Link to post
Share on other sites

OK so the camera came your car right ? and you just added the unit ? or you added the camera ?,OK by the looks of your plug i think you will need to get the PZQ60-00151 camera harness, but don't take my word on that , give it a try its $22 bucks ,i think its the right plug

don't forget the harness has speed sensor which goes to the purple wire in your steering wheel control plug, and you also have the reverse signal wire ,which is on the Gray plug on pin 5 ,but you might get away with just plugging the extra harness in if your car came with a camera ,it might be all done , here is the harness close up

sn2ccm.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Speed sensor is the purple wire ,

reverse signal wire is the red wire

Edited by sportivo2007
  • Like 1

Share this post


Link to post
Share on other sites

The female connector of the 151 harness is 28 pin while the connector comes out of my car is 20 pin bro. I think it needs some modification. I asked a toyota dealer but havent got respond. Hope they will help :)

Share this post


Link to post
Share on other sites

I tried to connect the red wire with the blue wire in 141 harness but it didnt work too. I think it needs a power source for the camera but I havent tried

Share this post


Link to post
Share on other sites

OK that's weird that's how i wired mine up and it worked fine ,and mine was an after-market too .

Share this post


Link to post
Share on other sites

ok here is the first one

sc5c8w.jpg

Hi bro, what is the part number of this harness? Thanks alot

Share this post


Link to post
Share on other sites

All done finally although it is too bright

Thanks sportivo2007 alot, I cant do it without your Help

CAM00284.jpg

Share this post


Link to post
Share on other sites

So you havent got new HU, I think there is some choices for you

A. Go to dealer, no headache but cost around $1500-$2000

B. Go to wrecker, got a used piece, do a DIY or Bring to dealer

C. Go a aftermarket.

Share this post


Link to post
Share on other sites

Ok, go ebay, search one, try to get a camry compactible, just plug and play. If you want to do a DIY, go to google and search "camry 2007 head unit replace" or some thing like that, that is the way I did. If something confused, come here and I ll try whatever I know.

But remember what you pay is what you get, so dont try too cheap

Share this post


Link to post
Share on other sites

Try to compare and search review any brand you going to buy :)

Share this post


Link to post
Share on other sites

All done finally although it is too bright

Thanks sportivo2007 alot, I cant do it without your Help

CAM00284.jpg

your welcome mate so the harness was the right one ?

Share this post


Link to post
Share on other sites

Uhm not really, I used 141 harness, add a 4 pin connector and connected reverse signal to pin5 of connector comes out of my car, if you want I can take pics

Edited by nhp

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...