Jump to content


Starting noises and engaging clutch


 Share

Recommended Posts

Hi all,

My sportivo (03) is making a whining/scraping noise when i start it off and when it engage the clutch. I changed my gearbox fluid and its a little better but not much of a difference when on cold start.

When i engage the clutch after its warm, the sound comes time to time.

Oil is near its max. Not sure if its the bearings or something.

Your help would be great :) Cheers

Link to comment
Share on other sites

its the throw out bearing

need to take the gearbox out

you have an option to fit a full clutck kit

the pressure plate may be damaged due to the faulty throw out bearing

how many km do you think the clutch has done ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 4

      2019 RAV4 oil filter wrench

    2. 0

      AE82 2zz-ge and 6spd swap

    3. 2

      2022 Toyota Camry Hybrid Should I buy it.

    4. 8

      2004 Sportivo RHS Headlight

    5. 4

      2019 RAV4 oil filter wrench

    6. 0

      kluger enhancements

    7. 8

      2004 Sportivo RHS Headlight

    8. 8

      2004 Sportivo RHS Headlight

    9. 7

      Collector pipe mod

Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...

Forums


News


Membership