Jump to content

Rough Idle ZZE122R


Recommended Posts

Hey guys,

Hoping someone could help me diagnose this problem. Fixing it isn't an issue provided I can figure out what it is.

Essentially at idle (doesn't happen when driving or at higher RPM) it seems to drop from the setpoint of about 1000 rpm to as low as 500 rpm. it hovers somewhere between 500 and 1000. hasn't cut out yet but it's gotten close and it sounds a bit rough sitting so low in the rev range. When the A/C is on it does bring the RPM up a bit so it seems to mask what is going on, although it still does drop (I imagine the A/C should take idle to around 1500 RPM but it sits somewhere between 1000 and 1500 somewhere, high enough to not be a problem but still showing the same symptom). I did adjust the idle pin a bit but it didn't really fix the symptoms, it still happens just at 200-300 higher RPM.

My first thought was the IACV, so I took this off and gave it a good clean out. It was pretty clean actually, on the engine intake side it did have a bit of a carbon deposit but this all cleaned off nicely. Put it all back in and it did improve the situation, but not hugely.

The thing is - it's been serviced recently by a mechanic (let's not argue about how good he is - I know he's good) but he couldn't replicate the problem. It's not throwing codes and it's not misfiring and the spark plugs are new. So I'm stumped.

If only I knew what to test or how to diagnose it better I could fix it. It hasn't caused me problems yet but it is a bit annoying. Car is perfect in all other ways.

Appreciate any help.

Edited by Shidoran
Link to comment
Share on other sites

Hello,

I am new to this forum. I have actually had this same problem in my 2005 Toyota corolla.

It very occasionally has a low idle. It has only happened several times and I have had it for 2 years, so it's not a big issue, but i'm interested that you have the same problem. For me, the rough idle usually occurs after starting the engine up when it is hot. It also seems to happen when the cooling fan comes on. 10 000 km ago i did a service on the car changing drive belt, coolant, spark plug, fuel cleaner, oil filter etc. Besides this occasional mishap the car has been an absolute gem with no other problems.

I so far haven't found what is causing this so i too would like so see if anyone knows.

Thanks

Link to comment
Share on other sites

Hey Tyce,

Your problem may be related to the IACV (idle air control valve). Mine may or may not be, but cleaning it out should be your first step for idling issues (it was my first step but my issue still remains).

It's pretty straightforward - try following this technique



Good luck!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...

Forums


News


Membership