Jump to content

LED headlight globe problem


rjcdani
 Share

Recommended Posts

I have recently installed new H4 LED globes in my Rav4 2004 Cruiser and have come across a strange problem that I cant workout, on high beam they work fine on low beam the high beam stays on as well as low beam. I have tried every possible polarity position and can be confident in saying that's not the issue.

Has anyone else had this problem when installing LED headlight globes in a Rav4 or any other car. Any help or suggestions would be appreciated.

Cheers

Link to comment
Share on other sites

Probably best to contact an auto electrician. Very few members would have done a LED headlight conversion because they are not road legal.

There are a few threads in the Camry and Aurion Forums where members have asked about LED headlights and been advised not to proceed. Better option [in my opinion] is to fit high performance halogen bulbs. An extra would be a LED lightbar wired into the high beam.

Personally, I have the Osram Nightbreaker Unlimited series under consideration for when i need to replace my headlight bulbs.

https://www.powerbulbs.com/au/store/category/car-bulbs/brand/osram/fitting/h4-472

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...

Forums


News


Membership