sharkwsk

***** while first gear change

Recommended Posts

Hi,

I have a Toyota Corolla, 2008 Sedan auto. Mileage - 87k

Last few weeks, my car is jerking badly during the first gear change. Also observing this when the car has warmed up a bit (few mins into a drive)

My local servicing technician advised me to take it to Toyota Transmission service center to get advise using their specialized diagnostic equipment..

Any hints on what could be the issue

Share this post


Link to post
Share on other sites
 

When was the last time the automatic transmission fluid changed? How many kms on the odometer?

Share this post


Link to post
Share on other sites

Took my car for a transmission checkup to a dealer. They suggested to change Transmission compressor spring and the Transmission fluid and quoted around 700$. What do you guys think ?

Share this post


Link to post
Share on other sites

Is it a suggestion that it will most likely fix your issue or a solid recommendation that it will definitely fix it?

Definitely get a 2nd opinion from a professional automatic transmission shop that has had previous experience with servicing your Toyota  transmission model. Check your vehicle's compliance plates for details of your transmission model e.g. U340E or U341E

Some internet searches revealed that Toyota released an upgraded valve body so this will determine which transmission filter is applicable to your vehicle.

Share this post


Link to post
Share on other sites

Technician told me that he has seen similar faults and replacement of this spring fixed them. He suggested he cannot be 100% but worth to change and check it....

I will check with other repairers and see

Share this post


Link to post
Share on other sites
2 hours ago, sharkwsk said:

Technician told me that he has seen similar faults and replacement of this spring fixed them. He suggested he cannot be 100% but worth to change and check it....

That sounds more positive for outlaying $700.

Share this post


Link to post
Share on other sites

Took it to another local mechanic. He had a test drive and advised me that it is some sort of a solenoid problem. Asked me to leave the car for him to check it and confirm. Sounded reasonable and confident..

Another transmission specialist did some further checks..

- Transmission oil and the color looks OK. 

- He suggested to do the compressor spring change and see if it fixes. Otherwise have to replace transmission with second hand one or do a reconditioning of the transmission

Any thoughts....?

Edited by sharkwsk

Share this post


Link to post
Share on other sites

I am not a transmission specialist.

In an online U340E tr ansmission repair manual, the troubleshooting guide lists 3 or 4 items to be checked for harsh shifting depending upon the gear change. It is going to be more a case of inspect and check to find the cause.

Share this post


Link to post
Share on other sites

Finally, my local mechanic sorted it out (for 800$)

Below is what he ended up doing

1. Flush and fill ATF, still the issue did not go away

2. Changed the transmission body valve and the problem went away

He did tell me that he has seen similar issues before on other cars....

 

Just wondering what could be the issue with these transmission bodies, one of the many valves could be faulty ?

Could it due to usual wear and tear or some faults ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now