Jump to content

Recommended Posts

Wondering if someone may have the same problem, I have a 2008 VDJ79 Landcruiser ute and it is a bit down on power. Boost lines are all good, especially on the back of the intercooler. If I drive the car calmly it behaves normally maybe with a little bit of rev and boost hesitation between gear changes or take off. But If i boot my foot down quickly regardless of being in gear driving or in neutral parked up the car hesitates for a second and then starts to rev up but won't go over 2800rpm or 6-7 psi boost. Driving normally or soft acceleration will allow it to go full rpm and 12-14 psi of boost. If anyone has any ideas please let me know as the mechanics cannot fault the car :dry:

Link to post
Share on other sites

Intake has not been cleaned as far as I'm aware, and it was serviced about 1000 km ago. So fuel filter is new. If it was choking that would make me think it would do it all the time? regardless of heavy or soft acceleration?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...