Recommended Posts

Hi guys wondering if anyone could tell me why my lift won't work /won't revo past 7000rpm just rev bounces I had the lift bolts replaced 4 months ago to stronger point lift bolts but today driving just didn't engage in lift and rev cut off at 7000rpm also I might mention when I turned the car off for 10minutes then drive again lift did work but only once then went back to not revving past 7000rpm any help would be great 

Share this post


Link to post
Share on other sites
 

Have you cleaned the filter sceen?

Share this post


Link to post
Share on other sites

If you've already replaced the lift bolts, it's safe to say you should check the following. Have you also performed any servicing, mods or other changes recently? Has lift engaged without problems before?

- Lift solenoid - May need to be cleaned.

- OCV filters as they can get clogged over time -

- Check any wiring - If there are any loose or broken wires.

- Possibly try an ECU reset.

Share this post


Link to post
Share on other sites

Hey squalled I must admit it hasn't seen a oil change for some time it's over by 2000kms so the video is everything I should check correct the lift engaged normaly before only a few days ago it's happen but when it did I turned the car off for 20minutes then drove again and it engaged but now nothing just revs to 7k and stops 

Share this post


Link to post
Share on other sites

15 hours ago, Domanic 2zzge said:

Hey squalled I must admit it hasn't seen a oil change for some time it's over by 2000kms so the video is everything I should check correct the lift engaged normaly before only a few days ago it's happen but when it did I turned the car off for 20minutes then drove again and it engaged but now nothing just revs to 7k and stops 

Definitely try some of those steps and give it a nice service. There's actually quite a few things I've seen over the years causing cars to not engage lift correctly.

As campbeam has shown, you can also remove the battery terminals to reset the ECU.

Share this post


Link to post
Share on other sites

Thanks a lot guys I'll get down to it tomorrow I'll will give an update when I get the things done 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now