Recommended Posts

Hi all I have a 2010 hilux sr. My speedo sometimes plays up zeroing at 40km/h and then other times at 80km/h.

Have any of you guys come across this issue it’s intermittent at best and really starting to annoy me.

when I turn the car off and leave it for 5 minutes it slowly resets to 0 on the speedo 

Share this post


Link to post
Share on other sites
On 7/22/2019 at 5:54 PM, Hilux77 said:

Hi all I have a 2010 hilux sr. My speedo sometimes plays up zeroing at 40km/h and then other times at 80km/h.

Have any of you guys come across this issue it’s intermittent at best and really starting to annoy me.

when I turn the car off and leave it for 5 minutes it slowly resets to 0 on the speedo 

Yep mine does similar 

I have been wondering how to fix it

A bloke on thiis site said to detach the speedo cable from the gearbox and  pull out the centre drive cable give it a clean and then lubricate it with Vaseline. He said it fixed his.

I figure I am gunna give it a go 

If it fixes it I will let you know 

If you find any answers or fixes I would love to know 😁

Share this post


Link to post
Share on other sites

If its a 2010 model it wont have a cable its electric 

Share this post


Link to post
Share on other sites
Just now, CONROD said:

If its a 2010 model it wont have a cable its electric 

Thanks mate good to know

Fortunately mine is a 1998 Hilux so I figure I will give your fix it idea a go.

I dont know what you would do with an electronic one

They sound like a real headache

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...