madscooterman

Diesel hiace cutting out

Recommended Posts

G’day everyone

First post and looking for advice

I have a 2007 3ltr D4D van with 2 issues,

When accelerating under load, and usually just as I hit 3rd gear (manual),it will lose all power as if it has lost all boost, it has about 5hp but idles fine, if I pull over and shut it down for a minute, it fires back up and off we go.

The check engine lamp comes on every time and goes out after an hour or so.

The strange thing is that it does not log any fault codes.

I have been told that it will be the turbo vanes sticking or a faulty turbo actuator.

I would like to be sure before outlaying a heap of coin.

Second issue is intermittently it will start, run for about 2 seconds, then shut down.

Then it will crank forever and not fire up.

If I remove the key, lock and unlock, it usually fires up, I’m a bit suss that it may be the immobiliser (Viper alarm) or a fuel pump on the way out.

Any help or advise greatly appreciated

Cheers Al

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.