domej

AFS doesn't work after replacing battery

Recommended Posts

hi guys, first post (woohoo)

as title says, my adaptive front lighting system doesn't work anymore. the afs button is unresponsive and i have no warning lights on the dash.

anyone lend a thought??

Share this post


Link to post
Share on other sites

should also add that they are hid and both turn on, they just don't swivel or level

Share this post


Link to post
Share on other sites

Hi Dominic and welcome to the forum. Are the headlights aftermarket by any chance ?

Share this post


Link to post
Share on other sites

afaik, headlights are the original ones

Share this post


Link to post
Share on other sites

You really don't give much background info here but Have a read of this

 

Edited by Tony Prodigy

Share this post


Link to post
Share on other sites
12 hours ago, Tony Prodigy said:

You really don't give much background info here but Have a read of this

 

afs was working before i replaced the battery, didn't afterwards

i came across a thread on a lexus forum to "initialise" the afs ecu using this procedure:

1. with engine running, headlights on and car in park, press "AFS OFF" button 8 times at 1 second intervals, (doesn't matter what position the switch was already in)

2. straighten steering wheel. if it was already straight, turn off centre and then re-centre.

3. press "AFS OFF" button twice at one second intervals without moving the steering wheel

4. after 3 to 10 seconds, repeat step 3

5. after 3 to 10 seconds, repeat step 3 again

6. after 3 to 10 seconds, repeat step 3 again

and now you have working afs 🙂

Share this post


Link to post
Share on other sites

I don't have a Presara so this is kind of new to me. 

So what you're saying is that if you replace the battery, you need to then re initialise the afs ?

So did the procedure work ?

Share this post


Link to post
Share on other sites

Same reply from me, did it work?..I have never had that issue with my Presara..I have replaced the battery and still had AFS working..so let us know if that procedure worked as it is a handy fix if it worked for you

KAA

Share this post


Link to post
Share on other sites

can confirm the procedure worked, afs is now swivelling and does the little dance on startup as before

  • Thanks 1

Share this post


Link to post
Share on other sites

Great news Dominic, will make a note of the procedure in case anything happens in the future..I always find the advantage of the AFS on a very dark night in a low ilight area useful..makes taking a corner so much easier and on a highway even better

Keep Well and Thanks for the information I am sure others will also benefit and that is why we are here..for each other.

KAA

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.