Jump to content


Map DVD


Podge
 Share

Recommended Posts

Hello everyone:) Just wondering if there is anyone out there who has had an issue with their stereo unit seizing up after a flat battery. We have a message which is frozen on the screen which says... No dvd, please insert map dvd. We have done this and the dvd is not re`setting the stereo unit. We can`t operate our radio/cd player, reverse camera is not functioning either. We have been told by one of the Toyota dealers that we may need to fork out 4-5k to completely replace the head unit:( Not keen on paying that expense just because we had a flat battery and our head unit has seized up. Any help would be much appreciated. TIA.

Link to comment
Share on other sites


6 hours ago, Podge said:

Hello everyone:) Just wondering if there is anyone out there who has had an issue with their stereo unit seizing up after a flat battery. We have a message which is frozen on the screen which says... No dvd, please insert map dvd. We have done this and the dvd is not re`setting the stereo unit. We can`t operate our radio/cd player, reverse camera is not functioning either. We have been told by one of the Toyota dealers that we may need to fork out 4-5k to completely replace the head unit:( Not keen on paying that expense just because we had a flat battery and our head unit has seized up. Any help would be much appreciated. TIA.

Hey Podge, sorry to hear of your bad luck. Toyota can charge some ridiculous prices sometimes too for parts...

Not sure what model you have but I have a 2011 kluger grande. There is a factory reset option on my multimedia unit, have you tried pressing that?

I would then try disconnecting the battery and reconnecting it again and seeing if that works.

Failing all that and if the stereo unit is really broken, I would find a replacement unit at the wreckers as 4-5k is ridiculous. I remember I had to find a replacement boot cover for my kluger and Toyota was going to charge about a grand for it, I found one at the wreckers for 200.

 

 

 

 

 

Link to comment
Share on other sites

Thanks for your reply:) I have a 2011 Kluger Grande aswell. The screen on our head unit is frozen so can`t access multimedia for factory reset option. Was worried about disconnecting the battery incase the immobiliser needs to be reset? Which might cost $$ too. Might try though...willing to give anything a crack now! Thanks again.

Link to comment
Share on other sites

the battery in my aurion went flat when i was running a copied map dvd (v26) and i lost all functions. i loaded in a genuine map dvd from 2008 (v15) and regained all functions. i then removed the genuine dvd and put in the copied one for the latest maps. 

  • Like 1
Link to comment
Share on other sites

  • 10 months later...
  • 1 month later...

Hey, my car is the same as yours and is doing the exact same thing. I was wondering if you found a solution? Toyota is saying I need a new map disc or a new head unit costing an arm and a leg! 
 

thank you 

Link to comment
Share on other sites

  • 5 months later...

Hi,

I have 2010 Toyota Kluger Grande. Last week, by mistake I removed Map DVD instead of Music CD and when I tried to insert it, it gives cracking sound and ejecting. I did this several times but not loading. Reverse Cam was working at that time. However, my battery went flat during this week and I put a new battery but now reverse cam is also not working. In short, whole unit is not working. It shows message "Insert CD" on unit. 

Can anyone help me how to sort out this problem without replacing unit please so that my unit accept Map DVD and it starts working both Navigation & Reverse Cam. I am residing in Blacktown area of NSW.

Thanks and look forward to someone's help.

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...
On 2/8/2022 at 1:33 PM, BadlyDrawnPie said:

Hi Giri,

I have the same issue with my 2008 Kluger Grande, did you find a solution.

Any luck yet??

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 34

      Coolant Leak 2008 Aurion

    2. 2

      Looking for a hard to find part

    3. 74

      White Pearl Paint cracking & peeling on a Prado

    4. 74

      White Pearl Paint cracking & peeling on a Prado

    5. 34

      Coolant Leak 2008 Aurion

    6. 34

      Coolant Leak 2008 Aurion

    7. 0

      looking looking

    8. 0

      Suspension

    9. 0

      How to change front wheel bearing 2009 corolla

Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...

Forums


News


Membership