Jump to content

Carolla ascent sport take off power / Revs drop


Recommended Posts

Hi all my first post, I have just bought a Carolla ascent sport 2014. 115000km , 6 speed manual. I have a driving school

and have noticed that at take off the revs drop off almost stalling. I am no stranger to manual as I teach manual in my driving school.

even on level road if i let clutch out slowly car shudders and i have to really keep revs up over 1.5, idle is just on 1. Once i get going its great after second there is instant power

and drives exceptionally well. checked one spark plug ngk platinum ? seems Ok?

any ideas how i can improve take off. 

Thanks

Ken

 

IMG20200818112612.jpg

IMG20200818112721.jpg

Link to post
Share on other sites

Maybe its time for a new clutch along with a full service i.e. Fluid change and a cleanup of the throttle body. Also give the maf sensor a clean. 

Link to post
Share on other sites

Hi Kroeger, was hoping to avoid a massive cost at the moment. I will try the other suggestions. thanks

Link to post
Share on other sites

Just had a look at the photos of that spark plug. It could possibly be a non-genuine NGK spark plug. So I would be inclined to change the spark plugs, clean the MAF sensor and the throttle body.

Link to post
Share on other sites

thanks Ashley will definitely change plugs, by the way do you know if i have to put the rubber sleeve over the top of the plug?

see foto

thanks

IMG20200818113226.jpg

Link to post
Share on other sites
12 minutes ago, kensteyn said:

by the way do you know if i have to put the rubber sleeve over the top of the plug?

Short answer is that I do not know.

However I suspect that the rubber sleeve is to keep dirt and oil out of the spark plug opening.

Best to put them onto the new spark plugs.

Link to post
Share on other sites
19 hours ago, kensteyn said:

Hi Kroeger, was hoping to avoid a massive cost at the moment. I will try the other suggestions. thanks

Sometimes it is unavoidable. But keep doing all you can before you take it to a professional. Cheers 

Link to post
Share on other sites
6 hours ago, kensteyn said:

thanks Ashley will definitely change plugs, by the way do you know if i have to put the rubber sleeve over the top of the plug?

see foto

thanks

IMG20200818113226.jpg

Not seen these before. Are they present on each plug? Perhaps contact these guys to get some information on the ignition system https://au.toyotaownersclub.com/profile/45808-swan-ignition-coils/

Link to post
Share on other sites

Umm... Judging by the hex shape around the base of the rubber boot I can't help but to think it is from the Inside of your spark plug socket there to help you get the spark plug out of the hole. 

  • Like 1
Link to post
Share on other sites

that makes sense. the rubber was in there when i took coil out. the spark plug socket got stuck in the tube around the rubber which i pushed down. i had to put some wd40 and twisted and pulled for about 5 min before i could actually get the socket out. so it been in there from whenever, i have only had car  for week now. Thanks Mark

i will assume it does not belong there. Could not find a name, but person from swan ignition coils has been great with advice and info

https://au.toyotaownersclub.com/profile/45808-swan-ignition-coils/

Link to post
Share on other sites
1 hour ago, kensteyn said:

that makes sense. the rubber was in there when i took coil out. the spark plug socket got stuck in the tube around the rubber which i pushed down. i had to put some wd40 and twisted and pulled for about 5 min before i could actually get the socket out. so it been in there from whenever, i have only had car  for week now. Thanks Mark

i will assume it does not belong there. Could not find a name, but person from swan ignition coils has been great with advice and info

https://au.toyotaownersclub.com/profile/45808-swan-ignition-coils/

If its part of the socket, it definitely doesn't belong on the plug when you replace them. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...