Jump to content

76 series starter motor not working


Scotty76series
 Share

Recommended Posts

Hi guys trying to find help/ advise on any common issues with starter motor. I've just completed a long trip from cape York back to brissie and my starter motor doesn't work. I'm wondering if it's the starter or a relay or something any advice or tips to check? Cheers guys

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 3

      2ZR Turbo

    2. 2

      Changing Coolant.

    3. 0

      2016 electric rear sunshade retrofit

    4. 52

      Engine Oil Change Interval

    5. 52

      Engine Oil Change Interval

    6. 4

      Coolant loss through overflow tube?

    7. 4

      Coolant loss through overflow tube?

    8. 4

      Coolant loss through overflow tube?

    9. 4

      Coolant loss through overflow tube?

    10. 4

      Coolant loss through overflow tube?

×
×
  • Create New...

Forums


News


Membership