Jump to content

Soft brakes 2011 Hiace


Spud 33
 Share

Recommended Posts

Hi All I am a newbie

Got a work horse Hiace 420K recently had a service buy the same mechanic who has looked after it from the day i bought it brand new.

Brakes changed just before christmas took longer to stop , so had the rear shoes and cyclinders replaced, front pads replaced. Mechcanic calls  saying it hasn't improve the feel of the pedal and travel, should proberbly change out the master cylinder could be the culprit considering the KMs and its never needed to be touched. So that was done all bled properly ...Not any better. Having checked the booster by disconecting the vac line pedal stays hard ruled that out.

Mechanic suggested it could be the ABS Module not working correctly, So he sent me to a specalist Brake and Clutch place after speaking to them we decided to get a ABS module from a wrecker as i needed to get it back on the road to earn a living asap. They were very busy i had to wait some time to get in but they have improved the pedal with the replacement ABS Module .

I say improved by about 40 percent  it seems to be working alot better ( the pedal dosen't go all the way to the floor like it used to before the ABS swap) but the pedal just dosent seem right.

I have spoken to others who say that the brakes are often soft on the Hiace and that i didn't notice it as drive with heavy work books on .

Having not replaced the booster could this be the problem? i was lead to belive that they either worked or didn't. Vac hose disconnected pedal is hard engine running.Have noticed today that there is a whooshing sound when you pump the pedal (engine off) (i missed this before due to road noise , radio etc) is this normal ?

Can booster provide to much boost?

there is no noticable change in revs at idle with it being a diesel.

No warning lights have come on at any stage . The system has been bled several times no air , by both my mechanic and the specalist. ABS is working .

Can anyone make any suggestions? has anyone ever heard of a simalar issue.

 

Help needed driving me nuts

Spud33

Edited by Spud 33
tags
Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 1

      Fenix radiator KUN26???

    2. 1

      Fenix radiator KUN26???

    3. 1

      Pistons for 69 Corona

    4. 1

      Pistons for 69 Corona

    5. 0

      LC200 Series GVM Upgrade

    6. 6

      2019 RAV4 oil filter wrench

    7. 6

      2019 RAV4 oil filter wrench

    8. 6

      2019 RAV4 oil filter wrench

    9. 0

      AE82 2zz-ge and 6spd swap

    10. 2

      2022 Toyota Camry Hybrid Should I buy it.

Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...

Forums


News


Membership