Jump to content

[Post Removed]


Recommended Posts

Spec_black you still have that big balled wolf as your avatar? lol

Blitz would be awesome. Heard a lot of good reports from the celica boys in the Cali area in the US. Very reliable. Many of them are daily drivers, one has had a blitz s/c installed with decomp. head gasket, diff. ratio pistons and he has no problems for 40,000k's and it's still going. 150 odd kw to the fronts and it runs a 1/4 in the late 13's early 14's.

You're getting a brake upgrade man...may as well do the motor now haha.

Link to comment
Share on other sites

Spec_black you still have that big balled wolf as your avatar? lol

Blitz would be awesome. Heard a lot of good reports from the celica boys in the Cali area in the US. Very reliable. Many of them are daily drivers, one has had a blitz s/c installed with decomp. head gasket, diff. ratio pistons and he has no problems for 40,000k's and it's still going. 150 odd kw to the fronts and it runs a 1/4 in the late 13's early 14's.

You're getting a brake upgrade man...may as well do the motor now haha.

nice mate

keep us informed:)

im highly interested in how you are going to work the suspension and what clutch setup you will be pursuing:)

Link to comment
Share on other sites

  • 1 month later...

i know for sure that RDA make both front and rears cause i have a set on my car, were around $170 each last time i checked, also would be nice to be able to find a bolt on caliper upgrade option too....

Link to comment
Share on other sites

Stage 1: Complete Brake Upgrade.

Can I ask what difference it makes to the stopping distance etc?

I play on the track a little, and have found that dropping from ~200kms to 60(end of striaght into hairpin) a few times, the brakes tend to soften a little, and it looked like the pads were getting a bit hot, so swapped them for TRD blue, which are good, but still after 6 or so laps they're softening, the liquid is already rated to ~800C which should be plenty, and fluid temp 'only' seems to be getting to ~400 :o , so I'm guessing it is probably the disks getting a bit too hot.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...

Forums


News


Membership