Jump to content

07 v6 kluger, long cranking time


Jeffro0
 Share

Recommended Posts

Hi. I have recently got a 2007 kluger,  7 seat , v6 petrol. Everything was fine for a day or so, now when going to start the vehicle it cranks for 10 seconds with a no start situation. Cycle key off and it fires normally as it should. I have inspected for DTC, and there was none present. I have a hunch its a fuel related issue. According to previous owner, coil packs, spark plugs all been replaced less than 10k km ago. 120k km on the odometer, spark plugs and coil packs replaced less than 10k km ago. 

Has anyone experienced anything similar? 

Link to comment
Share on other sites

Following YouTube video suggests that it could be an issue with the fuel pump or fuel filter. However, if your vehicle has only done 120K kms, then I would be a bit skeptical. I would start with checking the battery, cleaning/replacing the air filter. Something else to check is the Mass Air Flow {MAF} sensor and clean/replace.

This is another YouTube video worth the time to view.

https://www.youtube.com/watch?v=Pz7uhYKzvEo

 

 

Link to comment
Share on other sites

  • 2 weeks later...

Thanks for your reply. I'll give it a shot. Will check battery. Will clean out the maf and replace fuel filter. I've read online that the fuel pressure regulator on these sometimes stuff up but I'd rather not throw the parts cannon at it and diag it properly

Link to comment
Share on other sites

14 hours ago, Jeffro0 said:

Thanks for your reply. I'll give it a shot. Will check battery. Will clean out the maf and replace fuel filter. I've read online that the fuel pressure regulator on these sometimes stuff up but I'd rather not throw the parts cannon at it and diag it properly

Definitely sounds like a fuel related issue. A thorough check of the fuel system should reveal the root cause.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 0

      Hilux kun26 headlight upgrades to LED

    2. 41

      Coolant Leak 2008 Aurion

    3. 2

      Upgrading Ascent/Ascent Sport tail lights to SX/SL type LED tail lights

    4. 2

      Boot liner

    5. 5

      2004 hilux 3.4L auto issue going up hills

    6. 5

      2004 hilux 3.4L auto issue going up hills

    7. 2

      Boot liner

    8. 2

      Boot liner

    9. 41

      Coolant Leak 2008 Aurion

    10. 2

      Upgrading Ascent/Ascent Sport tail lights to SX/SL type LED tail lights

Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...

Forums


News


Membership