flopper

Regular Member
  • Content Count

    84
  • Joined

  • Last visited

Community Reputation

0 Neutral

About flopper

  • Rank
    Regular Member

Profile Information

  • Gender*
    Male
  • Toyota Model
    celica ZZT123
  • Toyota Year
    2003
  • Location
    New South Wales
  • How did you find us?
    Google
  • Annual Mileage
    50,001 upwards

Contact Methods

  • First Name
    big

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. How much work on top of buying that blitz kit from import monster would need to go into the sportivo? We talking about 7-10k all up for s/c, ECU, new brakes, LSD, exhaust piping and labour?
  2. Hey guys, ive got my TRD front strut brace and rear sway bars up for sale. Both in pretty much immaculate condition. The TRD front strut brace is no longer available, and im pretty sure the rear sway is heaps hard to come by these days. wanting $350 for the front strut brace and $200 for the rear sway bar. will post up pictures when i get a chance.
  3. PM superdave, hes the know it all on the powerFC
  4. whats the weight of those enkeis?
  5. I have a mate that lives around your area that might be selling his. It's a white 2005 sportivo with black eye lids, immaculate condition. Don't think he's posted it up on carsales though. I think I may have already been in contact with him, is his name Aaron? Yeah thats him
  6. I have a mate that lives around your area that might be selling his. It's a white 2005 sportivo with black eye lids, immaculate condition. Don't think he's posted it up on carsales though.
  7. thats normal for city driving. i get 500km per tank with city driving also,.
  8. Did you do stage 2 cam upgrade yourself... or did you have to take it professionals, if so how much was it? Cheers. He is a professional....
  9. hi guys, as the title states, im keen on buying a rear sway bar/rear torsion beam for my 05 sportivo. Thanks.
  10. i had a CES installed once upon a time ago, i certainly felt a difference in lift after i installed it, however your quite right- it drones badly. I went back to stock after about 2 months with it on (had to swap over as i started work at 5am and couldnt stand hearing the exhaust drone so early in the morning). Dont worry though, if you put it up for sale in this forum, it will get sold in a heart beat.
  11. Quick update, finally got it plugged with a rubber cap. Turns out the hose was the issue all along. Big thanks to prozak and superdave for the input. No longer switching off when in neutral. Will do a ECU reset on the weekend as it seems to be driving okay for the moment.
  12. I checked that blue cylindrical bit, and its already been blocked off. As for the actual CAI where the hose connects to it, im going to block it off with a 15mm grommet, is that the right plugging tool to use? Long as its blocked off bud ! Let us know how you go No worries. One more thing, once its blocked, should i reset ECU? or is there no need?
  13. I checked that blue cylindrical bit, and its already been blocked off. As for the actual CAI where the hose connects to it, im going to block it off with a 15mm grommet, is that the right plugging tool to use?
  14. Will do. Ill head to super cheap on Thursday to sort it out. Just a quick question, what is the blue cyclindrical thing and where is the plenum? And to Prozak, apologies, i thought everything was blocked off until i got feed back from everyone.