Jump to content

Marco233

Regular Member
  • Content Count

    5
  • Joined

  • Last visited

Everything posted by Marco233

  1. Aussie spec 2000-2002 would be similar to those 1990-1995 ones in the US. No OBD connection and lots of things still using 80s technology.
  2. Yep hoping my local wreckers have some for parts soon .
  3. Hi Tony I just pulled out the speed sensor and dash cluster. The speed sensor on our Aussie spec Corolla AE112 , however, is a pure mechanical part that connects directly to the dash with no electric parts at all. I found out the reason for my speedo stop working is that speedo cable jumped out of the socket on dash cluster. I put it back in and took it for a drive, however as soon as speed pick up to 50km/h the speedo is busted and jumping up and down and shaking again. I also checked speed sensor ,there is no teeth missing, just a little bit stripped on the edge ,as its a 20 years
  4. Hi Tony I would say the noise came from the dash. You reckon would it have something to do with tranny speed sensor? Because tranny had the problem the same day the speedo break down. I changed the tranny oil not long ago. And strangely the check engine light is NOT on .
  5. Greetings people so after making a ticking sound for weeks the Speedo along with ODO on my 2000 corolla AE112 decided to stop . The needle has been shaky since I had it . Now I’ve also noticed the car won’t go to 4th gear (could it be related with the speedo issues ?) any advices where I should start to look at TIA

Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...

Forums


News


Membership