Search the Community

Showing results for tags 'xrs'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • New Members
    • New Members Introductions
    • Forum Terms and Conditions / Buy & Sell Rules
  • Toyota Models
    • 86 Club
    • Aurion / TRD Aurion Club
    • Avalon Club
    • Camry Club
    • Celica Club
    • C-HR Club
    • Corolla / Corolla Sportivo Club
    • Hilux Club
    • MR2 Club
    • Prius Club
    • Rukus Club
    • Supra Club
    • Starlet / Sera / Paseo Club
    • Tarago Club
    • Toyota 4X4 / Kluger / RAV4 Club
    • Toyota Commercial
    • Yaris / Echo Club
    • Classic Toyota
    • Other Toyota Models
    • Fortuner Club
  • General
    • General Toyota & Other Car Discussions
    • Club Lounge
    • Members Rides
    • Lights, Camera......Action
    • Toyota / TRD Rally
    • Spotted - Been seen or seen others?
  • Traders Area
    • Sponsor The Club
  • Buyer and Sellers Corner
    • eBay Finds
    • Buy & Sell - Parts and Accessories
    • Toyota's For Sale
  • Workshops and Maintenance
    • Audio/Video/Electronics
    • Detailing - Show & Shine
    • Inside and Out
    • Suspension & Brakes
    • Wheels & Tyres
    • Workshop Submissions
    • Toyota Guides Support Topics
    • Tools & Equipment
  • Misc
    • Site Suggestions
    • Upcoming Club Meets & Events
    • Previous/Past Club Meets & Events
    • Club News & Announcements

Categories

  • Toyota General Guides
  • Toyota Aurion Guides
  • Toyota Avalon Guides
  • Toyota Camry Guides
  • Toyota Celica Guides
  • Toyota C-HR Guides
  • Toyota Corolla Guides
  • Toyota Fortuner Guides
  • Toyota Hilux Guides
  • Toyota Kluger Guides
  • Toyota LandCruiser Guides
  • Toyota MR2 Guides
  • Toyota Prado Guides
  • Toyota Prius Guides
  • Toyota Rav4 Guides
  • Toyota Rukus Guides
  • Toyota Supra Guides
  • Toyota Starlet / Sera / Paseo Guides
  • Toyota Tarago
  • Toyota Yaris / Echo Guides
  • Toyota 86 Guides
  • Classic Toyota Guides

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


ICQ


Yahoo


Jabber


Skype


First Name


Last Name


Toyota Model


Postcode Region


Location

Found 3 results

  1. So I have started to face this issue of sluggish/slow acceleration with my 2ZZ-GE AE80, I changed the fuel pump, spark plugs, cleaned lift solenoid but same issue persisted. I went from 97RON to 92RON fuel for some reason and all of a sudden the car does not hesitate during acceleration, what can be the problem. Car used to have popping sound from exhaust before there was this issue. Note: Water temp goes to 101ish and 2zz knocks due to 92RON while it never knocks or temperature never goes above 100C on 97 RON.
  2. Hey! So this Saturday I had a run with a 4age Toyota Ceres, was ahead by two cars' length in third gear (145kph) and mistakenly shifted to second gear instead of fourth gear , RPM went beyond 9k. Instantly I shifted to neutral and took it to the side. Now gear wouldn't shift while clutch pedal felt normal and engine was vibrating as if one ignition coil was not working. All the bad imagination comes rushing in since 2zzge isn't known to handle overrevs so well due to it's weak oil pump and also that it's an interference engine. So I put the car in neutral and ask some friends to push start the car fortunately the transmission shifted to second gear, 100 meters ahead car started to *****; similar symptom of a failed ignition coil, so we decided to tow it. Now at that time vibration had gone but recurred after a while. Next day went to a shop and asked my local mechanical stig (jk) to check the transmission, fortunately it was just a clutch disc (old but was fine) ,pressure plate and throw out bearing, shifting problem was gone but so did vibrations along with apparent misfiring/ignition problem. Now I can't make up anything out of these series of unfortunate events i.e. how can vibration & apparent ignition problem (assuming because car wasn't acceleration and was jerky) be gone after changing clutch disc and throw out bearing. Can anyone explain this? Also if anyone can suggest an easy way to check if I have some slightly bent valves or something. I tried Lift once after the incident and it feels normal.