Jump to content

2000 Camry wagon electric antenna problem.


TerryJay
 Share

Recommended Posts

My 2000 Camry Wagon antenna pole was severely damaged in a supermarket car park.

I purchased a new pole complete with nylon drive from the local Toyota dealer, watched the YouTube video re replacing same and proceeded with the task. The old pole and nylon drive was removed with ease as was the installation of the new one.

All works well except when the new pole reaches full extension, it continues to drive upward making a very disturbing sound. Similar happens when the pole is retracted, it drives fully retracted then continues to attempt further retraction in a very noisy fashion.

Do I need to trim the nylon drive cable or is there a problem within the drive mechanism itself ?

Advice / suggestions appreciated.

Link to comment
Share on other sites

What has probably happened is that the old cable had snapped off inside the motor and it is jammed in there.

Remove the new pole/cable, remove the motor unit from the car and disassemble it (it's only half a dozen screws). Pull apart the winding drum (noting how things go back together) and make sure all remnants of the old cable is removed. Then re-assemble the motor unit back together and put it back in the car, and re-install the new pole and cable as before.

I did this a few weeks ago (with genuine parts) and it works fine 95% of the time, occasionally it will graunch for a second or two, but only on extension and only if the initial extend was interrupted (ie I turned the radio on but started the car half-way through)

Link to comment
Share on other sites

When I purchased the pole and nylon drive cable the Toyota dealer said it was the same unit for a Camry as an Avalon, I'm wondering if this is not correct as the Camry is a wagon and the Avalon was only ever a sedan.

Link to comment
Share on other sites

When I purchased the pole and nylon drive cable the Toyota dealer said it was the same unit for a Camry as an Avalon, I'm wondering if this is not correct as the Camry is a wagon and the Avalon was only ever a sedan.

What was the part number of the one you bought? The Avalon one is identical to the Camry for the sedan, I'm not sure about the wagon though (the retainer and motor are probably different but I'd expect the pole/cable to be the same)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...

Forums


News


Membership