Jump to content


05 hiace ecu


Recommended Posts

Hi all, new member needing some help with an issue that has me stumped, replacing ignition and had a short somehow. Van would not crank or obviously start, found blown fuse and replaced, now car cranks but won’t start, no check engine light when ignition is first turned on and scan tool will not communicate with ecu. All fuses good except fuse 26 on instrument panel fuse box has no power.

almost convinced my ecu is cooked but before outlaying for a new one thought someone may either advise another possible cause or confirm ecu likely the issue, appreciate any advise or experience similar.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 3

      Typical Price for a Replacement Key - 2000 Toyota Torago

    2. 1

      Invisible Instruments fix

    3. 0

      Finally found all Tarago's 6 speakers - 2 in roof lining

    4. 0

      Can I use USB hub to get more USP ports?

    5. 1

      Replace Front RH park light Corolla 2006

    6. 1

      Rav4 smart key keyless entry

    7. 0

      What do I need to change for a 2.5in lift n70

    8. 1

      2005 Toyota Camry Altise - changing transmission fluid?

    9. 13

      Starter motor issues

×
×
  • Create New...

Forums


News


Membership