Jump to content


Landcruiser 100. Breaking rear upper control arms.


achris

Recommended Posts

Hello all.

I have a standard Landcruiser 100 (HZJ105) and I have just replaced the second broken rear upper control arm. First it was the left, about 6 months ago, now the right. Both broke at the HAZ, next to the weld, and at the body end (not the axle).... I have standard height suspension, with Lovell springs and Koni shocks. I'm wondering if anyone else is having this problem...

Thanks,

Chris......

P1000288_zps343aca36.jpg

Edited by achris
Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 1

      Central Locking works intermittently on rear passenger door

    2. 1

      1998 Toyota Celica Pricing idea

    3. 1

      1998 Toyota Celica Pricing idea

    4. 0

      Electrical issues with the 300 series

    5. 3

      Tyres

    6. 3

      Tyres

    7. 44

      Rav4 Transmission Problems?

    8. 2

      Rav4 2016 ZSA42R 2WD CVT failure

    9. 3

      Tyres

    10. 11

      FUEL WARNING MESSAGE

×
×
  • Create New...

Forums


News


Membership