Jump to content



bmes95

Recommended Posts

Hey guys,

I own an 07 sportivo..runs fine at any speed (no vibrations) however when going uphill, there seems to be a humming sound which becomes louder and louder.

My wheel alignment may be out of place, but wouldn't it humm on flat surfaces as well? Could this be the reason??

And also, since owning this car from September last year, I've had to get it aligned twice already. Is it my driving that constantly gets it out of place or could there potentially be other issues with the axle? maybe..

Should be taking it to a mechanic today to have a look.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 1

      Toyota Paint Defect Class Action

    2. 83

      White Pearl Paint cracking & peeling on a Prado

    3. 26

      Changeover manual A/C for Dualzone climate control

    4. 2

      Toyota Estima Air Conditioning

    5. 2

      Head Unit with Apple CarPlay

    6. 3

      Typical Price for a Replacement Key - 2000 Toyota Torago

    7. 1

      Invisible Instruments fix

    8. 0

      Finally found all Tarago's 6 speakers - 2 in roof lining

    9. 0

      Can I use USB hub to get more USP ports?

    10. 1

      Replace Front RH park light Corolla 2006

×
×
  • Create New...

Forums


News


Membership