Jump to content


1999 Rav 4 Electrical Faults ???


Cathy Daly
 Share

Recommended Posts

Engine light on, motor cuts out while travelling but restarts itself, but if stopped won't restart till motor cools down. Have been to Toyota, first said it was igniter but my model rav 4 doesn't have igniter. Have had car to autoelectrician who said it was maybe ignition relay which they replaced, tested coils/good. Checked out a few other things. Then called in mechanic, timing belt kit and $500 later. All to no avail, engine light still on and won't restart if hot. This car has been discussed by quite a few mechanics, seen by Toyota, seen by Autoelectrician and his referred mechanic hence timing belt replaced and no-one can find what is wrong with this car. Has cost me sooo much money so far and still have problem. i am not game to take it anywhere else, have lost all faith in so called car fixers. Any ideas or help would be appreciated as l am at my wits end. Have also renewed fuel pump and filter. I thought that you could just take these computerised cars to whoever and as long as they had scanner they could tell you what was wrong and needed fixing, apparently not. And now they want to charge me just to do the scanning.

Link to comment
Share on other sites

Even though they log fault codes unfortunately it doesn't always tell you what is wrong, it can help narrow down the cause of the issue but that's about it. between Toyota, the auto elec and mechanic surely one of them scanned the car and gave you a report on whats wrong?

If you were in Adelaide I could check the codes for you but it might be a bit far for you :)

To help narrow it down if you have the car running and parked does it eventually get hot enough and stop or is in only while you are driving?

Does it turn off while you are going around corners or driving straight?

It does sound like it might be from a component getting hot and shutting down... Bit beyond what I do but I'm guessing a sensor, if so reading the live data from the car with a scan tool should show this. it also might not be giving a fault from this issue.

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

hi brendan thankyou for your reply. everything you said has been done, autoelectrician has had the car for the past whole week now and still none the wiser. they have gotten info from toyota, scanned car etc. problem is definately electrical/sensor we all feel but because there is no real pattern to it it is hard to pick up. the cutting out usually occurs going straight or when l have stopped at shops and wont restart. wiile at autoelectricians they will run car for half to one hour and only sometimes will it cut out. they have tested sensors that they can find and readings are same going or not. but engine light is on all the time. what do l do if they cant fix it? thanks again, cathy.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...

Forums


News


Membership