AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Rollersk8r

Regular Member
  • Content count

    4
  • Joined

  • Last visited

  • Days Won

    1

Rollersk8r last won the day on August 25 2015

Rollersk8r had the most liked content!

Community Reputation

2 Neutral

About Rollersk8r

  • Rank
    Newbie

Profile Information

  • Toyota Model
    Aurion
  • Toyota Year
    2006
  • Location
    Australian Capital Territory
  • Annual Mileage
    15,000 to 20,000

Contact Methods

  • First Name
    James
  1. Leaking fluids are no longer the issue - I think that was an unrelated incident. The current/ongoing issue is the 3 warning lights - and additional whirring sound.
  2. Hi All - looking to reboot this thread as the problems have returned. The problem is precisely the same as it was before, with a combination of 3 orange warning lights on the dash. As soon as I start the car (in Park) the engine warning light comes on. Then, as soon as I put it in gear, the other two come on - VSC and the icon of the car with squiggly tire marks (also VSC???). Additionally, there seems to be an extra whirring noise (in addition to the normal engine noise). I'm not taking it back to Toyota, given all their previous failures to diagnose and fix the problem. May take it to another mechanic. Any ideas or similar problems reported??
  3. So the oil line has been replaced, for $600. And they've found a solenoid problem - a $1000 problem - that may need doing if I keep seeing warning lights come up... Brilliant. Kids, there are no Christmas presents this year...
  4. Hi all, Bit of a long story... I have owned this car for around 6 years and generally been pretty happy with it. However, around 12-14 months ago I began to get random warning lights coming up - mainly the engine and VSC (orange ones). They might come up a couple of times in a week, and then not again for months. Anyway - I have taken the car to Toyota dealers 6 or 7 times to chase up these errors, not including regular services - and basically got the same response each time: "Yeah we saw some error codes, couldn't find any problems during testing, cleared the codes, you're right to go". Then, about a month ago, I was finding the car would sometimes have a lag in engaging drive. The engine would rev and it would suddenly clunk into gear a couple of seconds later. So Toyota said this was beginning to sound like a transmission problems - and I should start by flushing and replacing the transmission fluid, which I paid around $200 to do. Then yesterday the engine starts making a horrible clattering sound. I was close to home and noticed it was leaking red fluid. I was fairly sure this was transmission fluid. Wasn't sure if I should drive the 5 or 6km to Toyota, but did anyway. Toyota are now saying this latest problem is nothing to do with transmission, it's leaking engine oil from a burst line, will be approximately $600 to repair - and they're not even sure if the engine is ok - because it did lose almost all of the oil. I have seen posts here and other stuff online about the V6 engine oil line and failures. But does this sound right to people?? I take obsessive care of the car. It has done 160,000km - but has cost me well over $1000 this year in servicing and repairs. Was hoping to get at least a couple more years out of it but I'm starting to wonder... Plus I was sold on the fact that Toyota keep comprehensive service records of the car, since before I owned it, which might avoid these sorts of issues coming up.