Jump to content

Both high and low beams stopped working on one side


Recommended Posts


I would suggest a visit to an auto electrician..could be a number of issues and could save you that horrible hunt down the problem experience

Hope it is a simple fix for you

KAA

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 0

      Squeaking and buzzing sounds

    2. 1

      Error Codes - 200 Series Landcruiser

    3. 3

      2014 VDJ200 Toyota Landcruiser Sahara Water pump

    4. 2

      New Vehicle Key Remotes

    5. 3

      2014 VDJ200 Toyota Landcruiser Sahara Water pump

    6. 3

      2014 VDJ200 Toyota Landcruiser Sahara Water pump

    7. 0

      Toyota Landcruiser V8 petrol lack of power on acceleration

    8. 3

      2014 VDJ200 Toyota Landcruiser Sahara Water pump

    9. 0

      Replace a none working 12v accessory plug

    10. 0

      2005 Toyota Camry Altise - changing transmission fluid?

×
×
  • Create New...

Forums


News


Membership