Jump to content


Recommended Posts

Hi

My Hilux submerged, deep enough for the key to stuck in the ignition. I have already done: drained, flushed, replaced all the oils; removed the glow plugs and got rid of unwanted water in the cylinders; stripped and removed the dash panel so all i can see is just wiring and all the different control units; removed every single plug on the interior loom, also opened all control units and cleaned it with electroclean spray. Now engine starts up fine revs up fine but has no power when in drive.The engine light stays on. Problem is no diagnostic tool(computer) is connecting with the vehicle so i am unable to see the fault codes. I have fitted a complete new wiring loom for interior with a new junction block and have tried with a new ECU still not connecting with any diagnostic tool??? Please help 

Link to comment
Share on other sites

You filled it with water, probably the worst possible thing to do to a car. This is probably not going to turn out well.

Have you checked the turbo and stepper motor? 

Have you ensured all connectors have gone back together correctly, especially to the OBDII port?

When water is involved, it is like a needle in a haystack.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 27

      FUEL WARNING MESSAGE

    2. 27

      FUEL WARNING MESSAGE

    3. 27

      FUEL WARNING MESSAGE

    4. 0

      Wanting to build my car.

    5. 0

      2004 hzj79 surging/jolting

    6. 6

      Australian customers gullible ?

    7. 0

      Gen 6 Cluster Backlighting Issues

    8. 1

      RZN149

    9. 2

      Windows wont work after Jump start

    10. 1

      Faulty speedo

×
×
  • Create New...

Forums


News


Membership