Jump to content

maybe problem 2004 manual rolla Please help


Recommended Posts

Hi upgrading the stereo in sister in law's corolla and i noticed evertime we took the battery terminal off and out it back on the gauges.. Speedo and tachno went all the way up to its higest point then sat back down slowely .. i have never seen this on my auto rolla or my manual bluebird

Is this a problem ? or normal.. ?

Edited by DrivInGScHool
Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 3

      Forum rules

    2. 13

      Low Fuel Warning Light Flashing

    3. 3

      Forum rules

    4. 1

      Starting Issue / Stalling While Driving

    5. 4

      2019 Kluger 2WD Transmission whine

    6. 0

      2001 hilux 2.7 efi low idle

    7. 0

      Toyota Prius 2012 code

    8. 8

      RAV4 19" wheels on Aurion

    9. 1

      Starting Issue / Stalling While Driving

    10. 0

      Starting Issue / Stalling While Driving

×
×
  • Create New...

Forums


News


Membership