Jump to content

2008 Corolla stalls at traffic light in drive, runs in P/N


Recommended Posts

My 2008 Corolla hatchback has broken down twice in the last week. Once last Friday, but was able to start again but would turn off when accelerating. Towed it to mechanic and that mechanic gave the following feedback: 

We can not fault car

Running fine

No error codes 

Charging as it should 

Possible crank sensor stalls when hot

Or alternator not charging but both working as they should 


Today (Friday) a week later I got a basic car service and crank angle sensor and air filter installed with another mechanic in hopes that was the issue. No error codes picked up either. I drove it soon after picking it up from mechanic (10 mins) when stopping at traffic light again, the car started losing power (shuddering) when accelerating and stopped and I'm able to turn the car on still in park mode but as soon as the you put it into 'drive' the car turns off. So worse then last Friday. The mechanic came to my location and managed to start it by rolling in neutral (while car was on) and put it into drive while rolling it and managed to restart it in drive mode and is now driveable again. However when I turned the car on in park mode tonight the p/s light, lights up momentarily and disappears. What could be the problems? No error codes have come up for two mechanics that have checked it. I don't think the p/s light was appearing when I first started the car prior to the basic repair today. Is this normal to appear when first starting the car and disappearing 2 seconds later while standing still?

The mechanic today asked me when was the last time I pumped the petrol and he mentioned that maybe there could of been water in the last fuel pump. Because I didn't have this issue before the fuel pump. But what are the chances?

I'm based in South East Brisbane if anyone could help suggest a mechanic that's a expert with Toyota Corolla issues like this please let me know who I can take it to as I'm a bit lost as I don't want to spend endless amounts of money on trial fixes with this intermittent issue.

And being on edge if my car will shut down again while driving.

Thanks in advance.

J

Link to comment
Share on other sites

12 hours ago, joeallen said:

When was the last time the timing belt was changed? If not for several years, a tooth on the belt may have fallen off and caused timing to be off.

'08 Corolla will be timing chain, not belt.

Link to comment
Share on other sites

On 11/25/2023 at 12:12 PM, jayontheblock said:

My 2008 Corolla hatchback has broken down twice in the last week. Once last Friday, but was able to start again but would turn off when accelerating. Towed it to mechanic and that mechanic gave the following feedback: 

We can not fault car

Running fine

No error codes 

Charging as it should 

Possible crank sensor stalls when hot

Or alternator not charging but both working as they should 


Today (Friday) a week later I got a basic car service and crank angle sensor and air filter installed with another mechanic in hopes that was the issue. No error codes picked up either. I drove it soon after picking it up from mechanic (10 mins) when stopping at traffic light again, the car started losing power (shuddering) when accelerating and stopped and I'm able to turn the car on still in park mode but as soon as the you put it into 'drive' the car turns off. So worse then last Friday. The mechanic came to my location and managed to start it by rolling in neutral (while car was on) and put it into drive while rolling it and managed to restart it in drive mode and is now driveable again. However when I turned the car on in park mode tonight the p/s light, lights up momentarily and disappears. What could be the problems? No error codes have come up for two mechanics that have checked it. I don't think the p/s light was appearing when I first started the car prior to the basic repair today. Is this normal to appear when first starting the car and disappearing 2 seconds later while standing still?

The mechanic today asked me when was the last time I pumped the petrol and he mentioned that maybe there could of been water in the last fuel pump. Because I didn't have this issue before the fuel pump. But what are the chances?

I'm based in South East Brisbane if anyone could help suggest a mechanic that's a expert with Toyota Corolla issues like this please let me know who I can take it to as I'm a bit lost as I don't want to spend endless amounts of money on trial fixes with this intermittent issue.

And being on edge if my car will shut down again while driving.

Thanks in advance.

J

I suspect fuel delivery issue. Either contaminated fuel or the filter is blocked, low fuel pressure or fuel pump is on the way out. A good mechanic would check fuel pressure at the fuel rail to the fuel injectors. If it eventually starts and runs, and NO error codes, then electrically it seems to be ok there. You have a non elec issue I think.

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 22

      200 series won’t shift past 4th gear

    2. 2

      Rear proximity sensor constantly makes sound in reverse.

    3. 2

      Rear proximity sensor constantly makes sound in reverse.

    4. 0

      Viscous fan & temperature gauge

    5. 0

      OBD Port in hiace 300 series ( 2019 model)

    6. 0

      centre console light replacement

    7. 4

      2GR-FE Oxygen Sensors

    8. 22

      200 series won’t shift past 4th gear

    9. 0

      When to replace Air Surge Plenum Gaskets

    10. 22

      200 series won’t shift past 4th gear

×
×
  • Create New...

Forums


News


Membership