Jump to content


Having problem with my 97/98 sxv20 Toyota Camry - Jerking,slow take off


Nero
 Share

Recommended Posts

Hi all,

Having problems with my 1997/1998 Toyota Camry,its an sxv20 4cyl auto 5sfe engine

Car has been jerking and takes off slowly during take off.Some small backfires when slowly taking off.I noticed if i hold one of the tubes/slim hoses behind the efi unit,the whistling sound goes away.Efi area making whistling and funny noise.I have put efi cleaner in fuel tank and has helped performance a little bit.Transmission oil is black,not sure if transmission is causing slow take off,but transmission needs servicing.Im guessing the problem is something to do with efi/electrical problem,a failed sensor/switch? bad contacts in wiring somewhere? Also I have to top up radiator with water once a week.I changed oil,oil filter and spark plugs about 6 months ago.A mechanic told me 6 months ago that engine is no good,needs new radiator,water pump,head gasket etc,but car has been running pretty good until recently.I dont think theres a blockage in the cooling system,since I refill radiator with water and/or collant once a week.The car is about 17 years old now (getting old) and i'm hoping some basic tests/maintenance will get the car running smoothly again.

Would it be worthwhile taking the car to Super Cheap Auto and let them do their $28 diagnostic test?

Any help/suggestions would be appreciated.I know a little bit about cars,but dont know how diagnose a problem like this

Cheers

Nero

brisbane-workshop (at) hotmail (dot) com

Link to comment
Share on other sites


If you're topping up the radiator once a week you either have a leak or a blown head gasket. Neither are good things and need to be checked out. Whistling sound is most likely a vacuum leak, this is also not a good thing (less critical than the coolant leak) and should also be fixed.

Sounds like the whole engine and transmission need a thorough going over and full service, which is probably what one of those $30 checks will tell you (and not much more). It is more than likely that multiple things are wrong and trying to diagnose exactly what will be difficult, so just start at the top and keep going until you get to the bottom.

Link to comment
Share on other sites



An update to my car problems

I looked at the leaking tube just behind the efi unit and put some
electrical tape around the slit (leak),the tube is now better sealed and
the performance of the car is almost back to normal! yay..but I know
there are other issues with the car but atleast I can now take off
quicker and car is jerking less now.ahh the magic of electrical tape lol
Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...

Forums


News


Membership