Help with car audio upgrades - 2001 Toyota Camry

Recommended Posts

Hello Everyone !

I've started to do some upgrades to my slightly old Toyota Camry. I replaced the headunit in favour of getting something with Android Auto, so I bought and installed a Sony XAV-AX100.

Works well, sound quality is good on the stock speakers (I think I had an upgrade from the factory 4 speakers + 2 tweeters in the front doors). Problem starts when I turn up the volume. Anything that is slightly on the louder side, and my music starts getting gaps in it, as if the headunit is lacking power and cutting out to not damage itself.

I've ordered a pioneer amp to potentially fix this issue, can push out 45W RMS at 4 ohms, but I'm not sure what the impedance of the stock speakers is. (Can someone help out?)

To be clear, the stock speakers used to go a lot louder on the stock headunit without distortion than what the Sony is cutting out at so therefore I don't believe the speakers are the problem. Stock headunit looks like this: and I think the model is 86100-YC280 by Fujitsu Ten.

Could someone shed some light on this and tell me if I am looking at this the right way and if getting an amp added to this will fix the issue? Is this issue due to an impedance mismatch?

Cheers :)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now