Jump to content


Cruise not working, Cruise light doesn't com on


idawood
 Share

Recommended Posts

Hi, 

I have Camry 2005 2.4l. Since I bought it, I never tried the cruise control but today when I tried to use it I realised that it's not working. Cruise light doesn't come on either. Any idea what to check? I saw another post regarding brake lights and cruise issue. My brake lights are working normally. They don't stay on as stated in that post. But I do have that missing rubber part as shown in that posts' pictures. 

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 1

      2010 camry altise fog/driving lights night photo

    2. 40

      VSC, Traction Control, Check Engine lights all on

    3. 8

      2016 Hilux loosing coolant Please help

    4. 1

      2010 Hilux engine light issues - PLEASE HELP!

    5. 3

      What spares to take touring

    6. 1

      Engine Starving for Diesel

    7. 87

      Long hard road…

    8. 1

      2010 camry altise fog/driving lights night photo

    9. 1

      U66OE tranny acts weird

    10. 1

      Engine Starving for Diesel

Toyota Owners Club AU © 2020 | This Website has no association with Toyota (AU) or Toyota Motor Corporation. | Cookies | Privacy Policy | Terms & Conditions

×
×
  • Create New...

Forums


News


Membership