Jump to content


need some info on installing a sony head unit in my toyota aurion


folklorians

Recommended Posts

hey guys. 

I'm new here I've bought a sony xav68bt double din head unit to upgrade Into my 2009 toyota aurion atx. with a genuine toyota facia pzq60 33030.

I've bought 2 aerpro harnesses for the head unit 

toyota - app0141

sony - app8sp3

I've connected these together but I've lost steering wheel controls? also the DVD player is coming up with "video blocked for your safety"

 

I'm looking to solve these problems.. hoping someone can give me done advice. do I need another adapter for the steering wheel control?? 

 

cheers

Link to comment
Share on other sites


4 hours ago, trentmeyer23 said:

Is the park brake applied?

I'd say the Aerpro loom just has the handbrake ground wire just hanging free/taped up, they don't ground through the harness and have to be manually connected to the handbrake switch to work properly (speaking from experience with the Kenwood DVD unit in Kevin) - or it can just be grounded permanently to bypass the handbrake switch (which is illegal but you probably won't get caught for it unless you're cruising down the highway and a cop sees you watching Fast and the Furious whilst driving...)

 

EDIT - I think it needs to be grounded, may be the opposite (ie +12V), there should be a wiring guide or installation manual that comes with the head unit telling you where it needs to be connected to

Link to comment
Share on other sites


27 minutes ago, Hiro said:

I'd say the Aerpro loom just has the handbrake ground wire just hanging free/taped up, they don't ground through the harness and have to be manually connected to the handbrake switch to work properly (speaking from experience with the Kenwood DVD unit in Kevin) - or it can just be grounded permanently to bypass the handbrake switch (which is illegal but you probably won't get caught for it unless you're cruising down the highway and a cop sees you watching Fast and the Furious whilst driving...)

 

EDIT - I think it needs to be grounded, may be the opposite (ie +12V), there should be a wiring guide or installation manual that comes with the head unit telling you where it needs to be connected to

thanks guys.. I'm a noob when it comes to car stereos .. i was just sick of the old basic aurion head unit with only mp3 cds... and radio haha 

I think the aerpro harness they've given me is actually wrong because ive been googling and it's saying the harness I need is app8sp4 not app8sp3?? I'm not saying this will solve my steering wheel problems. im thinking i need another adapter for the steering wheel controls, it looks like the App8sp4 has a longer wire coming off of it which I'm assuming is for the h/brake connection..

which the app8sp3 doesn't have... 

appreciate all the info! 

Link to comment
Share on other sites

2 hours ago, folklorians said:

thanks guys.. I'm a noob when it comes to car stereos .. i was just sick of the old basic aurion head unit with only mp3 cds... and radio haha 

I think the aerpro harness they've given me is actually wrong because ive been googling and it's saying the harness I need is app8sp4 not app8sp3?? I'm not saying this will solve my steering wheel problems. im thinking i need another adapter for the steering wheel controls, it looks like the App8sp4 has a longer wire coming off of it which I'm assuming is for the h/brake connection..

which the app8sp3 doesn't have... 

appreciate all the info! 

Yeah you have to be careful with adaptor harnesses for AV units as they often have more pins/features than standard ones, so just getting "Sony 16-pin 2013->" for instance doesn't guarantee that it'll work.

Link to comment
Share on other sites

 

4 hours ago, Hiro said:

Yeah you have to be careful with adaptor harnesses for AV units as they often have more pins/features than standard ones, so just getting "Sony 16-pin 2013->" for instance doesn't guarantee that it'll work.

yeah definetly haha i managed to take it back to repco 

toyota - app0141 

sony - app8sp3

grabbed some harnesses from super cheap grabbed a toyota Cht02c steering control module harness which bypasses the app0141. 

and also app8sp4 for the Sony head unit and also needed a APSONYPL patch lead for the steering wheel control module 

followed the other steps grounded the hbrake cable so it now plays dvds! haha!

now it's working! except the only problem is my volume button works on my steering wheel and not the other toggle switch to skip songs or change "mode" etc..  not sure if that's how it is or I've missed something! cheers 

 

Link to comment
Share on other sites

all fixed! had to open up the control harness module... end change the toggle number 4 switch to off .. which gave me full steering wheel controls!! I'll upload a picture later when it's all installed 

appreciate all the help !

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




  • Join The Club

    Join the Toyota Owners Club and be part of the Community. It's FREE!

  • Latest Postings

    1. 1

      RZN149

    2. 2

      Windows wont work after Jump start

    3. 1

      Faulty speedo

    4. 1

      2012 Hilux 3.0 D4D starts, runs for 30 seconds then stops

    5. 1

      2012 Hilux 3.0 D4D starts, runs for 30 seconds then stops

    6. 24

      FUEL WARNING MESSAGE

    7. 24

      FUEL WARNING MESSAGE

    8. 24

      FUEL WARNING MESSAGE

    9. 0

      Hilux 2017, 2.8 diesel dual cab - alternator

    10. 32

      toyota 700

×
×
  • Create New...

Forums


News


Membership